X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how do i change my default search engine in firefox 4?

Posted

At present my search engine is powered by babylon ..it got installed with some download manager.

Chosen solution

OK, go to about:config again, then keyword.URL, double click it and then add the following: http://www.google.com/search?q=

It's a link, so right click it in this post and choose "Copy Link Location" to copy it to the Windows clipboard. Then you can just do a CTRL+V to paste it. Saves you having to type it all.

Read this answer in context 17

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r152
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Xircal 334 solutions 3835 answers

Helpful Reply

Please follow these instructions.


  • In the location bar, type about:config and hit Enter.
  • In the filter at the top, type: keyword.URL
  • Double click it and remove whatever's in there. You'll see it revert to "Default" and "String".
  • Go to File | Exit
  • Restart Firefox, go to the site you want to set as your homepage.
  • Go to Tools | Options | General.
  • Make sure it says "Show My Homepage" in the first dropdown menu.
  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.
Ryan 20 solutions 231 answers

If you click on the drop down arrow next to the search box a drop down menu will appear allowing you to choose which search engine you would like to use.

Question owner

Xircal your instructions were truly helpful, i removed that babylon thing. but now it created another issue..suppose i type google in the address bar and hit enter then that term should be searched by the default engine i have set, right? but its not happening, i just arrive at the page i have set as my search engine. see the image, it does shows that i've enquired that particular term but lands at the search home page. notice the word google i've highlighted.

please help. anything will be appreciated..

Xircal 334 solutions 3835 answers

Chosen Solution

OK, go to about:config again, then keyword.URL, double click it and then add the following: http://www.google.com/search?q=

It's a link, so right click it in this post and choose "Copy Link Location" to copy it to the Windows clipboard. Then you can just do a CTRL+V to paste it. Saves you having to type it all.

Question owner

hail you Xircal!! and thanXs.

Xircal 334 solutions 3835 answers

You're welcome. :)

drsreedhar 0 solutions 1 answers

hai xircol ,thank u for writing

EvanC0912 0 solutions 3 answers

Okay, I was dealing with this problem, too. Now, I've come up with the solution. My Firefox 4 Start Page is now using the Google search engine!

Follow these simple steps:

  1. Type "about:config" on the URL bar and press Enter. This will bring you to the browser's control panel.
  2. If a warning happens to show, just ignore it. Rest assured. We are not altering any major parts that will lead to failure. Therefore, just click the "I'll be careful, I promise!" button.
  3. You'll be brought to a page with various parameters and values of settings. To make it faster and easier, a filter bar is provided on the upper part of the window, just bellow the URL bar and Toolbars. Type "browser.search.order.1" on the Filter bar. Only 1 entry will now be listed. Reset the setting value (right-click > Reset). The value should now reset to "Google". If the value doesn't change to "Google", simply double-click the value and type it manually.
  4. Go back to the Filter bar and type "browser.search.defaultenginename". Again, reset the value so that it changes to "Google". If the value doesn't change to "Google", simply double-click the value and type it manually.
  5. It's done! Close the tab and you can try searching with Google on your Firefox 4 Start Page. The "Google" logo will now be shown to the left of the search text area.

I hope this guide solves your problem. Good luck!

cesc4 0 solutions 1 answers

both xircal and EvanC0912 solution works... but it will change back to previous search engine (which the one that i dont want) when i restarted the browser. how to solve this please...could someone help me :(

Xircal 334 solutions 3835 answers

Open about:config again, go to keyword.URL and add the following URL: http://www.google.com/search?q=

It becomes a link in this post, so right click it, choose Copy Link Location to copy it to the Windows clipboard, then CTRL+V to paste. Saves you typing it all.

Do you have a chat app called Digsby installed? It (re)installs babylon as your search engine every time you start it if you didn't specifically opt out. See http://techshali.com/digsby-instant-messenger-and-email-manager-social-networks/

cookin_in_mac 0 solutions 1 answers

Worked for me! Thanks for sharing your knowledge Xircal! Easy to follow instructions as well.

rickrick 0 solutions 3 answers

Xircal,

Great Work on showing how to get rid of unwanted tool bars and resetting search engines. Thank You for showing how to "get under the Hood" in firefox ! WORKS FOR ME! rickrick