Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I'm running Firefox 4, but my Browser is not supported

  • No replies
  • 14 have this problem
  • 2 views
more options

Browser Requirements

K12 requires web browsers to support certain features to ensure you don't experience unexpected errors

Please follow the instructions below to enable the features required by K12 before logging in. If you feel your browser meets the requirements or would like to continue to login, please click the login link at the bottom of this page.

Web Browser

This website currently only supports Microsoft Internet Explorer 7.0 or 8.0 (IE 9.0 is not supported) and Firefox 3.x. Your browser is currently not supported.

Please use the links below to install/update your browser: - Firefox - Firefox Download Website - Internet Explorer - Microsoft Internet Download Website (Windows only