X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

(Error code: ssl_error_renegotiation_not_allowed) how do I fix this for my bank?

Posted

I try to log onto my bank with the new Fox fire and I continually get this error. I have looked through your list and can find no way to fix this. I have tried to go back and download Fox Fire 3.6 but can't find it. It worked with the last fox fire, but not the new. I really like the look of the new, but if I can't access my bank information it is hard for me to use foxfire.

Additional System Details

Sites Affected

http://www.harleysvillesavingsbank.com

Installed Plug-ins

  • npmnqmp 071101000050
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • iPhoto6
  • Coupons Inc. Plugin
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Simple plug-in that handles Citrix connection files
  • Shockwave Flash 10.1 r102
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

ecure Connection Failed
An error occurred during a connection to www.harleysvillesavingsbank.com.
Renegotiation is not allowed on this SSL socket.
(Error code: ssl_error_renegotiation_not_allowed)
The page you are trying to view can not be shown because the authenticity of the received data could not be verified.
Please contact the web site owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

cor-el
  • Top 10 Contributor
  • Moderator
10747 solutions 96723 answers

See:

wrojas 0 solutions 1 answers

Helpful Reply

Para habilitar la renegociación SSL se necesita modificar un parámetro del navegador. Escribiendo en la barra de direcciones about:config y tras confirmar que sabemos lo que queremos hacer... buscamos la siguiente directiva:

security.ssl.allow_unrestricted_renego_everywhere__temporarily_available_pref

Y modificamos su valor por defecto a TRUE

Después de esto ya se podrá acceder al sitio web que daba el error.

sctl 36 solutions 219 answers

Helpful Reply

@wrojas:

Setting the following config entry to "true" is not recommended:

     security.ssl.allow_unrestricted_renego_everywhere__temporarily_available_pref

RFC 5746: "It's not desirable to set this to true, as it completely disables the new protection mechanisms. ...It's highly recommended to leave this at the default value "false", and instead populate preference:

    security.ssl.renego_unrestricted_hosts 

with a list of hosts that require the exception."
http://tools.ietf.org/html/rfc5746

For users whose banks have not yet implemented better security, send the bank a copy of the RFC and tell them to get their act together. Or bank somewhere else.

henrys007 0 solutions 1 answers

It worked perfect for me.