X
Tap here to go to the mobile version of the site.

Support Forum

I used to be able to enter partial url address in location bar and firefox would come up with the full address or best match. Now it just indicates host not exists, check url address or try google search. So now I have to enter complete address.

Posted

I have a mac os x ver 10.6.6 and firefox version 3.6.16. I installed an HP Photosmart D110a printer (had a HP printer before that died) this morning. This evening, all of a sudden, I started getting the "host does not exist" message when I would enter a partial url address in the location bar of my home igoogle page on firefox. Usually, firefox automatically completes the url, I hit return and my website comes up. Now I just get the does not exist screen. I also had to update Adobe a couple of days ago.

I have a mac os x ver 10.6.6 and firefox version 3.6.16. I installed an HP Photosmart D110a printer (had a HP printer before that died) this morning. This evening, all of a sudden, I started getting the "host does not exist" message when I would enter a partial url address in the location bar of my home igoogle page on firefox. Usually, firefox automatically completes the url, I hit return and my website comes up. Now I just get the does not exist screen. I also had to update Adobe a couple of days ago.

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • The DjVu plug-in allows you to view DjVu files. For more information, visit the LizardTech web site.
  • iPhoto6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r102

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16

More Information

I tried looking at firefox support info on internet keyword search and domain guessing and it looks like all those settings are correct. Mine is set to google search and not yahoo search (I left as is).

cor-el
  • Top 10 Contributor
  • Moderator
17483 solutions 158000 answers

Helpful Reply

You can modify the pref keyword.URL on the about:config page to use a Google Lucky search.


To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

You can modify the pref <b>keyword.URL</b> on the <b>about:config</b> page to use a Google Lucky search. * http://kb.mozillazine.org/Keyword.URL * http://kb.mozillazine.org/Location_Bar_search ---- To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br />

Question owner

Thanks. Tried "Lucky", "Yahoo", and "Google" on the website which was a little different than the "Google" I have in about:config. None of them worked. About ready to give up and type in the whole name. Thanks again.

Thanks. Tried "Lucky", "Yahoo", and "Google" on the website which was a little different than the "Google" I have in about:config. None of them worked. About ready to give up and type in the whole name. Thanks again.

Question owner

Not going to believe this but after posting above message, I went ahead and typed "city cards" and it worked but it doesn't work for "citycards". Oh well.

Not going to believe this but after posting above message, I went ahead and typed "city cards" and it worked but it doesn't work for "citycards". Oh well.
cor-el
  • Top 10 Contributor
  • Moderator
17483 solutions 158000 answers

Make sure that the Location Bar is not set to "Nothing":

  • Tools > Options > Privacy > Location Bar: When using the location bar, suggest: History, Bookmarks, History and Bookmarks
  • Smart Location Bar

If you type two words then Firefox knows that you want to search. With one one then Firefox first tries a DNS query with some fixed up versions of that word to see if any exist.

Make sure that the Location Bar is not set to "Nothing": * Tools > Options > Privacy > Location Bar: When using the location bar, suggest: History, Bookmarks, History and Bookmarks * [[Smart Location Bar]] If you type two words then Firefox knows that you want to search. With one one then Firefox first tries a DNS query with some fixed up versions of that word to see if any exist.
Helper7677 165 solutions 1653 answers

Helpful Reply

There is a change in Firefox 4 in how Location bar search works.

  • In Firefox 3.6.x, Location bar search uses Google "Browse by name" search. With the browse by name search, it performs a Google search and
    • if there is a clear match it will take you to the site
    • otherwise it shows the Google search result page
  • Firefox 4's default is
    • to perform a Google search and present the Google search results page if you type something which is not recognized as a URL
    • you must type a complete URL, such as www.youtube.com , to go directly to the site

To get the Firefox 3.6.x behavior in Firefox 4. you need to change a hidden preference.

  1. Type about:config into the location bar and press the Enter key
  2. If you see a warning, zccept it (promise to be careful)
  3. A list of preferences will open
  4. Filter = keyword.URL
  5. Double-click on that preference in the lower pane
  6. A small window will appear; copy the line below and paste into the box in that small window (or type it into the box in that window exactly as shown below):

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

See:

There is a change in Firefox 4 in how Location bar search works. *'''''In Firefox 3.6.x''''', Location bar search uses Google "Browse by name" search. With the browse by name search, it performs a Google search and **if there is a clear match it will take you to the site **otherwise it shows the Google search result page *'''''Firefox 4's default''''' is **to perform a Google search and present the Google search results page '''''if''''' you type something which is not recognized as a URL **you must type a complete URL, such as www.youtube.com , to go directly to the site *'''<u>Also make sure you</u> **are remembering Browsing History: Options > Privacy, [X] Remember my browsing history ***see: https://support.mozilla.com/en-US/kb/Options%20window%20-%20Privacy%20panel **<u>do not clear "Browsing History"</u>''' when using Clear Recent History or when closing Firefox : ***see: https://support.mozilla.com/en-US/kb/Clear%20Recent%20History To get the Firefox 3.6.x behavior in Firefox 4. you need to change a hidden preference. #Type '''''about:config''''' into the location bar and press the Enter key #If you see a warning, zccept it (promise to be careful) #A list of preferences will open #Filter = keyword.URL #Double-click on that preference in the lower pane #A small window will appear; copy the line below and paste into the box in that small window (or type it into the box in that window '''''exactly''''' as shown below): http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= See: *http://kb.mozillazine.org/About:config *http://kb.mozillazine.org/Keyword.URL *http://kb.mozillazine.org/Location_Bar_search

Modified by Helper7677

Question owner

Thanks again for the info. Location bar is set to history & Bookmarks. I have history and bookmarks. Checked about.config. Keyword.url is the google line. I even retyped it. Read the info on about.config, keyword.url, and location_bar_search. I give up. Hopefully the next upgrade will take care of it.

Thanks again for the info. Location bar is set to history & Bookmarks. I have history and bookmarks. Checked about.config. Keyword.url is the google line. I even retyped it. Read the info on about.config, keyword.url, and location_bar_search. I give up. Hopefully the next upgrade will take care of it.
skanchi 0 solutions 1 answers

I just followed the following steps and the location bar with predictive text started to work.

1. Restart your browser in safe mode by following the instructions provided on the following link. http://support.mozilla.com/en-US/kb/Safe%20Mode?s=safe+mode&as=s#w_how-to-start-firefox-in-safe-mode

2. No go to Tools and click on add-ons. Enable your add-ons.

3. Close the browser and open it again.

Your predictive URL function should start working for you.

I just followed the following steps and the location bar with predictive text started to work. 1. Restart your browser in safe mode by following the instructions provided on the following link. http://support.mozilla.com/en-US/kb/Safe%20Mode?s=safe+mode&as=s#w_how-to-start-firefox-in-safe-mode 2. No go to Tools and click on add-ons. Enable your add-ons. 3. Close the browser and open it again. Your predictive URL function should start working for you.

Modified by skanchi

Question owner

Didn't know you could do this. Tried but didn't help. I don't have any add-ons. Thanks!

Didn't know you could do this. Tried but didn't help. I don't have any add-ons. Thanks!
hippodance 0 solutions 1 answers

Awesome tip Thanks, worked like a charm just did what you said to do. BTW it works on 5.0 which is what I am using. Thanks again.

Awesome tip Thanks, worked like a charm just did what you said to do. BTW it works on 5.0 which is what I am using. Thanks again.

Modified by hippodance