Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox keeps defaulting to gcoogle.co.uk dispite virus scans and modifying the default value :S

  • 3 replies
  • 32 have this problem
  • 13 views
  • Last reply by actan

more options

It seems like i have some unknown malware/spyware/virus that is affecting my browser.

The homepage keeps defaulting to gcoogle.co.uk and opens loads of surveys and other rubbish.

I have run malwar/spyware and anti-virus programs and even deleted my firefox profile to no avail. Any ideas would be much appreciated.

All Replies (3)

more options

is there a fix yet

more options

I have a temporary solution until the malware is identified. It apears that the hompage setting for firefox is also related to the internet Explorer.

Simply redirect the www.gcoogle.co.uk to the ip address that belongs to www.google.co.uk. To do this, close all Browsers & follow the steps below:

1. click start > run & type: attrib -r %windir%\system32\drivers\etc\hosts

2. click start > run & type: notepad %windir%\system32\drivers\etc\hosts

3. after the line: 127.0.0.1 localhost on the next line type: 209.85.227.106 www.gcoogle.co.uk

4. File > Save & then File > Exit

5. click start > run & type: attrib +r %windir%\system32\drivers\etc\hosts

6. click start > run & type: ipconfig /flushdns after a few seconds open your browser you should see a google homepage.

If for some reasons it did'nt work or that you are on a corporate/ enterprise network & would like to deploy this to many PC's then tell your network administrator to point the DNS record for www.gcoogle.co.uk to the IP: 209.85.227.106 on the DNS server.

_________________________________ Moksud Miah

Modified by Moksud

more options

After getting this annoyance, I decided to trace the problems. and here's the result. Locate your user.js file in your firefox profile directory space. usually in the format C:\Documents and Settings\{user}\Application Data\Mozilla\Firefox\Profiles\{anyletters}.default

Edit it with notepad and you will see the line:

user_pref("browser.startup.homepage", "http://gcoogle.co.uk/");

change it to the default you needed or delete both these lines

user_pref("browser.startup.homepage", "http://gcoogle.co.uk/"); user_pref("browser.startup.page", 1);

Solved!!! Happy Firefoxing.....