Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 4 sucks! Why can't I save my tabs when closing Firefox, & why can't I have a red X to stop a slow page from loading?

  • 17 replies
  • 218 have this problem
  • 68 views
  • Last reply by garciahe

more options

NOT FASTER!! MUCH SLOWER!! When I close Firefox, I can no longer save my tabs. WHAT GIVES? When a new page isn't coming up, I can no longer stop it from loading & try again. WHY do my tabs need to be above the toolbars? I've loved using Firefox & have used it exclusively for about the last ten years, but if this is how it's always going to be now, I'm going to look for a new browser!

moderator edited the title of this thread

Modified by the-edmeister

Chosen solution

One change in Firefox 4 is to by default stop Firefox displaying the warning message, but it can be turned back on by changing some preferences.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference browser.tabs.warnOnClose, if its value is set to false, double-click on it to change its value to true
  4. Repeat this for these 3 preferences browser.warnOnQuit, browser.warnOnRestart and browser.showQuitWarning

If you always open the last set of tabs, an alternative approach is this:

  1. Click the orange Firefox button, then select options to open the options window
  2. Go to the General panel
  3. Change the setting "When Firefox starts" to "Show my windows and tabs from last time"

In Firefox 4 by default the Stop, Go and Reload buttons are combined and attached to the right hand edge of the location bar.

When you are typing in the location bar it will show the Go button. When a site is loading it shows the Stop button. At other times it shows the Reload button.

If you want separate buttons, right-click on a toolbar and choose Customize, you can then drag and drop the stop or reload buttons and place them elsewhere. If you place them in the order "Reload-Stop" on the right hand edge of the location bar they will be combined again. For more details on customizing the toolbar see https://support.mozilla.com/kb/How+to+customize+the+toolbar


If you don't want tabs on top, right-click on a toolbar and click on the "Tabs on Top" entry to de-select it.

Read this answer in context 👍 66

All Replies (17)

more options

Chosen Solution

One change in Firefox 4 is to by default stop Firefox displaying the warning message, but it can be turned back on by changing some preferences.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference browser.tabs.warnOnClose, if its value is set to false, double-click on it to change its value to true
  4. Repeat this for these 3 preferences browser.warnOnQuit, browser.warnOnRestart and browser.showQuitWarning

If you always open the last set of tabs, an alternative approach is this:

  1. Click the orange Firefox button, then select options to open the options window
  2. Go to the General panel
  3. Change the setting "When Firefox starts" to "Show my windows and tabs from last time"

In Firefox 4 by default the Stop, Go and Reload buttons are combined and attached to the right hand edge of the location bar.

When you are typing in the location bar it will show the Go button. When a site is loading it shows the Stop button. At other times it shows the Reload button.

If you want separate buttons, right-click on a toolbar and choose Customize, you can then drag and drop the stop or reload buttons and place them elsewhere. If you place them in the order "Reload-Stop" on the right hand edge of the location bar they will be combined again. For more details on customizing the toolbar see https://support.mozilla.com/kb/How+to+customize+the+toolbar


If you don't want tabs on top, right-click on a toolbar and click on the "Tabs on Top" entry to de-select it.

Modified by TonyE

more options

Thank You !!!

more options

You're welcome

more options

The described fix seems to work fine, and I appreciate the fast response.

Firefox developers, I've been a developer myself. Setting the default to not save tabs in Firefox 4 is going to make a lot of people VERY angry.

I'm a fairly educated user. After upgrading, the first thing I did was to check Preferences and try to make sure all settings were good to maintain what I've been accustomed to doing. I didn't take the Firefox 4 tour, but shut down the application to make sure caches were emptied. There was no warning about my multiple tabs, but it was too late to stop the process. When I opened it again, all my tabs were gone, some of which related to material or local logins that I will have a hard time re-creating.

If my wife had done this, you would have heard her swearing without benefit of phone or online chat window, no matter where your labs are. :-)

For everyone's sanity, please don't turn off the Preserve Tabs on Logout function without warning.

more options

You might also point out that under History there is a Restore Previous Session option that will recover the bookmarks. Thank you for this!

more options

Yes thanks a lot it worked!

more options

Also please note that the "stop loading" (X) button is now at the right end of the page address bar while a page is in the process of loading, and it changes to a "reload page" button when the page is done loading. This saves the space of having two separate permanent buttons, but you do have to look a bit harder for it than the old, larger buttons. Since these are used relatively rarely by most people, no need to make them too large, separate, or permanent.

more options

I had exactly the same experience as Andrew_in_NH, and did not enjoy it!

Modified by morris5

more options

Thank you, Andrew! I was so lost in this new version and just wanted my old session back! You've been a great help.

more options

A couple of days later I closed Firefox, and my tabs were gone when I started it again. The Restore Previous Session function (under History menu) does still work. I'm disappointed that the "about:config" modification didn't stay in place.

By the way, running Firefox 4 on a Mac, I don't see an orange Firefox logo that I can click to open an Options menu. Under Firefox: Preferences, the General tab has the On Startup pulldown menu. That is where we can tell it to reopen the previous windows and tabs.

Modified by Andrew_in_NH

more options

My two cents on this is that this functionality was pioneered by Firefox, is a main reason that many people moved to Firefox (behind tabs in general) and that defaulting to No obliterates all reason for non-technical people to use it, given IE and Chrome default to warn.

It was a terribly bad UI decision and whoever leads that team needs to be taken to task for it, and I would vote for replacing them.

Modified by Guilden_NL

more options

I agree. One EASY step to revert to the previous version: http://www.mozilla.com/en-US/firefox/all-older.html

more options

my FF4 does not restore previous session at all, no matter what. Instead, when I start FF4 it opens up 4-8 strange looking windows with dual title bars. https://support.mozilla.com/en-US/questions/810136#answer-166397

more options

The 'X' does not appear on the panel with other tool-bar options.

more options

Man-o-man, I am SO glad to be rid of Firefox 4 and back to 3.6 !!!

I really hope that Mozilla Firefox has been reading these complaints. If they want to ensure that those using Firefox stay with them, they'd better get back to the drawing board and completely revamp that crappy 4.0 version!

ACK- Firefox 4 is beyond pathetic!

more options

wow! firefox4... I had to go back to 3.6.17 in a few hrs, In firefox 4 i got lots of, page can not be found and everything eles. I thought there was something wrong with my comp, but after installing 3.6.17 everything is fine again. I gave 4 a try and i can say i wont be updating again.. Seems they wanted to make it like google chrome or somthing, but if i wanted google chrome , i would have downloaded google chrome...... I must say from what ive seen FAILFOX4 SUCKS !! Whats worse? there trying to make failfox 4 the norm, firefox 3.6.17 will only have updates and such for a short time. the balance of this posting was deleted by a moderator due to language and the lack of any redeeming social value

Modified by the-edmeister

more options

I loaded a new version of FireFox and now my Google toobar went away. I went to Google to reload it and FireFox wont let me. Why? If there is a way show me how to install it back on.