X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I want to remove restore previous session button

Posted

Firefox home page has a "restore previous session" button. How can I remove this button?

Additional System Details

This happened

Every time Firefox opened

This started when...

Immediately after downloading Firefox 4

Installed Plug-ins

  • Abacast Netscape Plugin
  • Photodex Presenter Plugin 4,00,0,2442
  • Office Plugin for Netscape Navigator
  • DivX® Web Player
  • 12.0.1.609
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.2 r153
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Google Update
  • Adobe Acrobat Plug-In Version 6.00 for Netscape
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Session Manager has no settings for this. Tools/options ditto.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96803 answers

That button is part of the build-in about:home page. You can set another page as your home page if you do not want that button. That entry can also be found in (Firefox >) History > Restore Previous Session. If all tabs are closed before closing Firefox then there is nothing to restore.

Question owner

Thanks for your response. I do close the tabs prior to closing the window. However, when I close the window after closing the tabs and then hit the restore button, it appears on the last page I visited, not the home page. Also, if the back and forward arrows still navigate to pages I've closed in tabs -- including those that are password-protected, even if I've logged out. Not good for a multiple-user machine. I find some value in an uncomplicated home page, although one could choose another. But that still leaves the functional problem on Firefox. My solution was to revert to the last highest version of Firefox 3.6.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96803 answers

Helpful Reply

Are you using Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time" ?

If you immediately close Firefox after closing tabs then Firefox may not update sessionstore.js properly causing some tabs still to get opened, so you may try to wait 10 seconds to see if that helps.

Question owner

Thanks, Cor-el (any relation to Kal-el or Jor-el?). I've tried the settings you mentioned & they don't seem to help. What does seem to work best is closing the window after closing the tabs, then immediately re-opening and re-closing the window -- that makes the last session an empty session, so it does solve the problem but is kind of tedious. I've tried the various steps in session manager and tools/options that are related to this, but none of them solve the problem. There were some related suggestions in the faq's that involve going to the about:home page and changing settings (I may have that address wrong -- the page has a bunch of settings alphabetically arranged on it) -- but that doesn't do it either.

ElvenFaery 0 solutions 1 answers

Helpful Reply

I, too, am frustrated by the eternal presence of this button on my startup page. It even seems to be fully functional if I've cleared my history before closing my previous session. While I'm not overly concerned with my privacy, as sometimes I unexpectedly would like to access something from my last session, I'd still prefer this button to be gone. There seem to be ways of configuring the browser to eliminate this constant option, but I don't want to disable the ability to restore after there has been a crash. Has anybody found a solution that simply makes the button go away, not just render it useless (because the last session was the homepage)?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96803 answers

The only thing that helps is to close all tabs or open a second (blank window) and close the window with the tabs.

You can always set a different page as your home because that Restore Previous Session button is part of the new about:home Home page. That will however still leave the same entry in the History menu to restore the previous session.

akley 0 solutions 1 answers

Start firefox go to 'tools', then 'options', select 'privacy' in the 'firefox will:' box select 'use custom settings for history' then check 'clear history when firefox closes' and then ok.

Modified by akley