X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why is Firefox 4 so very SLOW?

Posted

Upon installing Firefox 4, I was made painfully aware that the Mozilla people had just released a browser which proceeded to HOG my resources and bring nearly everything on my MacBook Pro to a standstill. Just when I thought Safari was slow, enter Firefox 4, the slowest, clunkiest experience yet. Don't get me wrong. I do like Firefox. Actually, I reverted back to the last version, which works just fine, but hey, Mozilla, if you're going to create a new version of your browser, maybe you should take the time to make it perform better, not kidnap my system's speed.

Additional System Details

This happened

Every time Firefox opened

This started when...

I installed Firefox 4

Installed Plug-ins

  • Displays PDF documents in the browser.
  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • npmnqmp 071303000006
  • Picasa plugin.
  • http://www.facebook.com/fbplugin/
  • Simplifies the uploading of photo files.
  • MacCinema
  • iPhoto6
  • Office Live Update v1.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • DivX Web Player version 2.0.2.39
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Java Plug-In 2 for NPAPI Browsers
  • 4.0.51204.0
  • Version 1.9.2.1599
  • Google Talk Plugin Video Accelerator version:0.1.43.4
  • Shockwave Flash 10.2 r152

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16

More Information

Replace Firefox 4 with Firefox 3.6. Perhaps they'll get their act together on 4.1?

Anonymous 0 solutions 12 answers

do a clean reinstall......

disable unnecessary addons and plugins..

these addons can help speed up day-to-day operations

https://addons.mozilla.org/en-US/firefox/addon/startupservice/

https://addons.mozilla.org/en-US/firefox/addon/fasterfox-9148/

https://addons.mozilla.org/en-US/firefox/addon/speed-dial/

fiftyone 0 solutions 1 answers

Helpful Reply

disable unnecessary addons and plugins..

This is just stupid advice. One of the major pluses of this browser is or was plugins / addons. What you are saying here is that although there are a bunch of awesome addons for Firefox, you should disable them if you want Firefox to have decent performance. What deems a plugin or addon "unnecessary" anyway?

Oh but wait... then you proceed to say that they should install 3 new addons... lol wtf?

RichKD 0 solutions 13 answers

Firefox beginning with 4.0 can no longer be placed in any "Applications" sub folder, must be upper most "Applications" folder. Example; Applications ➢ Internet ➢ browsers ➢ Firefox 4.0.1.app, hangs. Applications ➢ Firefox 4.0.1.app, no apparent problem. If your Firefox 4.xx is in any other folder, drag it to "Applications" only. At least that seems to be the fix for me.

Modified by RichKD

simonett 0 solutions 1 answers

Helpful Reply

Not just laptops!. Firefox 4 has my 27" iMac with: {2.93GHz Quad-Core Intel Core i7; 4GB 1333MHz DDR3 SDRAM - 2x2GB; and HALF EMPTY 1TB Serial ATA Drive}, axle-wrapped for 10 MINUTES on startup. Learned immediately after upgrading, must keep FF.app file in top level Application folder. Now, CLEAN install? What does that even mean? Must I rely on Chrome, Safari and (shudder) IE? Has Mozilla reached the max it can do with Firefox??

alan_r 58 solutions 753 answers

Just a note that you are talking to fellow users here who have volunteered to help, not mozilla.

For this advice you'll need to re-install Fx4.0.1. Fx3 will start to lack support before long.

Just for starters, you could look up Problematic Extensions e.g. Firebug is a renowned memory hog.

Next, you could try disabling Hardware Acceleration - Options>Advanced>General>Browsing> uncheck "Use Hardware Acceleration..."

Then you try Safe Mode to identify culprits and conflicts. Work your way through this -

https://support.mozilla.com/en-US/kb/Troubleshooting%20extensions%20and%20themes

Make sure your plug-ins such as Flash are up-to-date. Try disabling third party toolbars.

I'm sorry but there is no easy way. For the record, my Fx4 with plenty of extensions, a non-default theme and a fair amount of customization is working beautifully. It looks good, too. You should try, until things settle down, to keep your Firefox as lean as possible and in default state. FasterFox is very unlikely to help.

Modified by alan_r