X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I'm not being able to restore Google's I'm feeling lucky functionality in Firefox 4

Posted

Hello, Since I've been using Firefox 4 I've also been trying to restore the Google's I'm feeling lucky functionality back to my browser experience (which is a shame this edition has removed it from default), however I'm being unable to do so. I've tried some Firefox add-ons, and I've also tried to change settings at about:config. Forums and Google search haven't help much so far. Why? Because no matter what I do, the values will always turn back to the new FF4 default values next time I restart my computer. In other words, my changes don't cling. This ius the defaul value at about:config: chrome://browser-region/locale/region.properties. No possibilities to change that for good. As an example, I've just typed "Firefox" at my address bar. Here's the page it's opened: jar:file:///C:/Program%20Files/Mozilla%20Firefox/omni.jar!/chrome/en-US/locale/browser-region/region.propertiesfirefox "File not found Firefox can't find the file at jar:file:///C:/Program Files/Mozilla Firefox/omni.jar!/chrome/en-US/locale/browser-region/region.propertiesfirefox. Check the file name for capitalization or other typing errors. Check to see if the file was moved, renamed or deleted." Is there anyone who can help? I suppose that the only thing that's really important here is that someone let me/us know how to KEEP the changes at about:config, otherwise, no matter what you do there, next time you reboot your machine everything will be as always, and your setting changes will be gone. I hope the folks understand my explanation. Thanks a lot for your time and assistance.

Modified by plafstudiesdotcom

Chosen solution

There is a change in Firefox 4 in how Location bar search works.

  • In Firefox 3.6.x, Location bar search uses Google "Browse by name" search. With the browse by name search, it performs a Google search and
    • if there is a clear match it will take you to the site
    • otherwise it shows the Google search result page
  • Firefox 4's default is
    • to perform a Google search and present the Google search results page if you type something which is not recognized as a URL
    • you must type a complete URL, such as www.youtube.com , to go directly to the site

To get the Firefox 3.6.x behavior in Firefox 4. you need to change a hidden preference.

  1. Type about:config into the location bar and press the Enter key
  2. If you see a warning, zccept it (promise to be careful)
  3. A list of preferences will open
  4. Filter = keyword.URL
  5. Double-click on that preference in the lower pane
  6. A small window will appear; copy one of the lines below and paste into the box in that small window (or type it into the box in that window exactly as shown below):

See:

Read this answer in context 19

Additional System Details

This happened

Every time Firefox opened

This started when...

I installed Firefox 4

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • np-mswmp
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 12.0.1.633
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Shockwave Flash 10.2 r153
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • wpidetector
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

None

Question owner

Hello! It seems that if you set the keyword.enabled (the type is boolean) to false you'll have the Google I'm Feeling Lucky functionality back. To do so, type "about:config" in the address bar. Click on "I'll be careful, I promise!". Type or copy keyword.enabled and paste there; Now click twice on it until you see a change from "true" to "false" under Boolean. Done! After doing so, the result should be: Preference Name: keyword. enabled; Status: user set; Type: boolean; Value: false. I've noticed not everything you type in the address bar will be recognized. You must type all together, letters and numbers only, without space. There must be a better way. This is only until someone finds it and lets us know. Have a great day!

Modified by plafstudiesdotcom

jarihu 0 solutions 2 answers

about:config

keyword.URL

http://www.google.com/search?ie=UTF-8&oe=utf-8&q=

Modified by jarihu

Question owner

Thanks, jarihu. I've already tried that, but the problem is that it doesn't cling and remain. When you restart your browser/system everything is back to how it was before. I hope someone finds a better way. Have a great day!

Helper7677 165 solutions 1653 answers

Chosen Solution

There is a change in Firefox 4 in how Location bar search works.

  • In Firefox 3.6.x, Location bar search uses Google "Browse by name" search. With the browse by name search, it performs a Google search and
    • if there is a clear match it will take you to the site
    • otherwise it shows the Google search result page
  • Firefox 4's default is
    • to perform a Google search and present the Google search results page if you type something which is not recognized as a URL
    • you must type a complete URL, such as www.youtube.com , to go directly to the site

To get the Firefox 3.6.x behavior in Firefox 4. you need to change a hidden preference.

  1. Type about:config into the location bar and press the Enter key
  2. If you see a warning, zccept it (promise to be careful)
  3. A list of preferences will open
  4. Filter = keyword.URL
  5. Double-click on that preference in the lower pane
  6. A small window will appear; copy one of the lines below and paste into the box in that small window (or type it into the box in that window exactly as shown below):

See:

Modified by Helper7677

Question owner

Dear Helper 7677, Wow! So far so good. It really appears this time the setting will cling and remain. I've closed and opened the browser after doing as per your tutorial, and... bingo! It worked. Thanks a lot. This will help many people. You're a hero! Have a great day!

Helper7677 165 solutions 1653 answers

Helpful Reply

plafstudiesdotc

You are welcome.

So that other users can find answers that have worked, please take a couple of minutes to return to the forum, sign in and click "Solved" next to my answer. Thanks.

Question owner

Hello, Folks, Greetings! I'm back here to say that the issue has returned in Firefox 8 (maybe in 7, too). All the information above has become outdated. The point is: the modification we make doesn't cling or remain at keyword.url. After restarting the browser it is back to its default, with nothing on it. Please let me know how to be able to restore the Google I'm feeling lucky functiuonality. It's very useful to me and I'd appreciate any asistance. Thanks a lot in advance.

Modified by plafstudiesdotcom