Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

To be compatible with a state medicare site I need Firefox 2.0. Is it available?

  • 2 replies
  • 2 have this problem
  • 2 views
  • Last reply by zjollyjoker

more options

I work in a doctors office. We must verify insurance eligibility through a state website that is only compatible with Firefox 2.0. Is it available to download from your site? Thank you.

All Replies (2)

more options

It is available from https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/2.0.0.20/win32/en-US

Have you tried a more recent version of Firefox? Could Firefox 2.0 be the minimum requirement? Firefox 2 is in computing terms very old, it is no longer supported.

more options

First, thank you for the 2.0 question as this bullet proof lean ver. is not available on the Firefox web page for older versions.

Second, if you have an interest in an upgrade-- absolutely positively check the resource requirements of the version.

For example, FF 3 will not work on a WIN ME system.

FF 4 will not work on many systems only a few years old.

In the meantime, think hard about clicking that "upgrade" button that FF keeps yipping and yapping about at each browser launch.