X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to prevent "Download Complete" box to pop-up?

Posted

Recently I downloaded Firefox 4. I also use "Download Statusbar"; "Download Helper"; "Free Download Manager plugin" and "Status-4-Evar" Add-Ons. With this configurations a notification box called "Download Complete" started to appear at the bottom-right corner of the screen. Previously I had never seen this. I have already checked the Net and the knowledgebase. All answers are related to the earlier versions and do not work now. I cannot figure out which add-on (or Firefox itself) opens this box.

Additional System Details

Installed Plug-ins

  • BitDefender QuickScan Web Netscape Plugin
  • np-mswmp
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • 4.0.60129.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96699 answers

Helpful Reply

You can set the pref browser.download.manager.showAlertOnComplete to false on the about:config page.

I do not know if any of the extensions that you mentioned above will override this setting. So you may have to check that yourself.
See:

Question owner

As I stated in my question, I had done my homework and tried to modify that setting. Default value was already "false". I had also checked the options of the other downloads related add-ons carefully. But, I cannot figure out if any of those extensions override that setting. Everything seems all right. I have also sent the same question to the support team of the "FDM". Thanks for the answer, anyway.

Question owner

Free Download Manager support team answered this question promptly.

Obviously, I missed the "Options > Settings > Notifications" setting of FDM.

Problem solved.

Thanks.