Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 4 (Mac), view source feature does not work?

  • 15 replies
  • 173 have this problem
  • 942 views
  • Last reply by ajweb

more options

When I right-click on a page and select "View Source," nothing happens. The same thing happens when I try to view the page's source via the Web Developer plugin.

Chosen solution

You rock shmeeps. This still isn't fixed in version 8.0

Read this answer in context 👍 0

All Replies (15)

more options

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:


You can also check these prefs on the about:config page.

more options

same here, no view source feature, no view image info neither.

more options

As requested, I tried starting in safe mode, with addons disabled.

I still have the same problem. Nothing appears to happen when I choose Page Source form the View menu. Also, typing command-U does nothing.

I'm using FF 4.0 for Mac OS 10.6.6.

more options

Also, as suggested, I checked my preferences:

view_source.editor.external is set to false (i.e. use internal view source) view_source.editor.path is empty

more options

The issue here - but it seems to be an issue with opening new windows, not just the view source feature. e.g. Ctrl-N doesn't work either. However I can see the list of windows that are open in the Window toolbar, just can't actually see them.

more options

I tried starting Firefox 4.0 in Safe Mode, and I still could not view the page source.

view_source.editor.external -- Status = default | Type = boolean | Value = false view_source.editor.path -- Status = default | Type = string | Value is blank

Neither of these fixed my problem. Again, I'm using Firefox 4.0 on Mac OS X 10.6.7.

This is really kind of an annoying problem, as I'm a Web developer and use the "View Page Source" feature quite often. Granted I can still use Firebug, but sometimes I just want to see the full page of source code without all the added features.

more options

So I just made a discovery. I have two screens; when Firefox is on the main screen, I can right-click and view the pages' source code. However, when I'm on the secondary monitor, I can right-click and select "View page source," but nothing happens. Weird.

Does this sound like a Firefox issue, or a Mac OS X issue?

more options

@mkimitch - Thanks for that, it seems to be my problem on my Mac too. Main screen it operates fine. (nothing happens when trying to open a link in a new window either)

Other programs seem to work (old firefox, safari, chrome etc) so my guess it's a firefox 4 issue.

more options

mkimitch, occurs the same here.

I've noticed too that only in main display the "cmd+u" gives me the source code. In second display, nothing happens.

more options

FYI on my MBP this problem occurs only if the secondary monitor is to the left of the primary. If the monitor is to the right the source screen shows up on the primary monitor.

more options

A workaround to this problem is to set your view_source.editor.path to an external editor. I'm using TextMate here and it works even on the secondary monitor.

Here are my settings:

view_source.editor.external = true

view_source.editor.path = /Applications/TextMate.app/Contents/Resources/mate

Modified by Rodrigo Sieiro

more options

We use MBPs at work, and I was having the same problem, very inconvenient since I work as a web developer and administrator. I fixed this, as per mkimitch's suggestion about 2 screens, by modifying the screen arrangement properties. Basically, I went from this arrangement

http://i.imgur.com/law6z.png

to this arrangement

http://i.imgur.com/hEqbA.png

Noticed the SLIGHT adjustment in the secondary screen downwards to be flush with the top of the primary screen. View source now works perfectly. Hope this helps someone.

more options

shmeeps solved it!

more options

Chosen Solution

You rock shmeeps. This still isn't fixed in version 8.0

more options

The arrangement of the screens is not a good solution in my case (although it works perfectly), so I opted to install this plugin, View Source Chart: https://addons.mozilla.org/en-US/firefox/addon/view-source-chart/?src=search.

It solves the problem in a colateral way by just opening the source in a Tab instead of a new window. Plus you get a very nice structured code view, so highly recommended anyway.