Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot save tabs on exit

  • 7 replies
  • 99 have this problem
  • 1 view
  • Last reply by dr.ilangho

more options

I just upgraded to Firefox 4.0 on on Windows XP PC and lost the ability to save browsing tabs on exit.

I looked at the troubleshooting information in Firefox Support and tried to implement it with no success. sessionstore.js did not have the js extension. I added the extension but I still did not get a dialog box asking whether to save the tabs.

I do a lot of research and writing, so this is an important feature for me.

Chosen solution

One of the changes in Firefox 4: by default Firefox 4 does not display the "Save Tabs and Exit" warning message when closing multiple tabs, but it can be turned back on by changing some preferences.

  • Saving tabs was not removed from Firefox 4, but it works a bit differently.
    • By default, Firefox 4 will not ask to save tabs, but instead it will always save your tabs on exit. You can restore them next time by choosing "Restore Previous Session" from the History menu, or pressing the restore button on Firefox's default home page.
    • Note: This was a decision by the developers. On this forum, we are all uncompensated volunteers here to help other users. The developes/employees of Mozilla/Firefox rarely, if ever visit here.

Also make sure you do not clear "Browsing History" when using Clear Recent History:

To display the "Save Tabs and Exit" message when closing multiple tabs, you can do the following:

  1. Type about:config in the URL/Location/Address bar and press the Enter key
  2. Accept the warning message (promise to be careful)
  3. The preferences page/list will open
  4. Filter = browser.tabs.warnOnClose
  5. If its value is set to false, double-click on it (in the lower panel) to toggle its value to true
  6. Repeat steps 4 and 5 for these following 3 preferences also:
    • browser.warnOnQuit
    • browser.warnOnRestart
    • browser.showQuitWarning
  7. See:




You need to update the following plugins:

  • Shockwave Flash 10.2 r152
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  1. Check your plugin versions on either of the following links':
  2. Update the Flash plugin to the latest version.
    • Download and SAVE to your Desktop so you can find the installer later
    • If you do not have the current version, click on the "Player Download Center" link on the "Download and information" or "Download Manual installers" below
    • After download is complete, exit Firefox
    • Click on the installer you just downloaded and install
      • Windows 7 and Vista: may need to right-click the installer and choose "Run as Administrator"
    • Start Firefox and check your version again or test the installation by going back to the download link below
    • Download and information: http://www.adobe.com/software/flash/about/
      • Use Firefox to go to the above site to update the Firefox plugin (will also install plugin for most other browsers; except IE)
      • Use IE to go to the above site to update the IE ActiveX
    • Download Manual installers.
  3. Update the Java plugin to the latest version.




After updating Java to the current version 1.6.0.24 (see above), you need to remove old versions of Java Console in your Extensions (You can see them in: Firefox button > Add-ons > Extensions OR Tools > Add-ons > Extensions if you are using the Menu Bar instead of the Firefox button). Link to instructions for removal are below. You have these old versions currently:

  • Java Console 6.0.12 true {CAFEEFAC-0016-0000-0012-ABCDEFFEDCBA}
  • Java Console 6.0.13 true {CAFEEFAC-0016-0000-0013-ABCDEFFEDCBA}
  • Java Console 6.0.14 true {CAFEEFAC-0016-0000-0014-ABCDEFFEDCBA}
  • Java Console 6.0.15 true {CAFEEFAC-0016-0000-0015-ABCDEFFEDCBA}
  • Java Console 6.0.17 true {CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}
  • Java Console 6.0.19 true {CAFEEFAC-0016-0000-0019-ABCDEFFEDCBA}
  • Java Console 6.0.20 true {CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}

Leave only Java Console 6.0.24 true {CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}; you may disable that in the Extensions if you are not a Java developer/programmer.

See instructions: http://kb.mozillazine.org/Java#Multiple_Java_Console_extensions

Read this answer in context 👍 28

All Replies (7)

more options

Chosen Solution

One of the changes in Firefox 4: by default Firefox 4 does not display the "Save Tabs and Exit" warning message when closing multiple tabs, but it can be turned back on by changing some preferences.

  • Saving tabs was not removed from Firefox 4, but it works a bit differently.
    • By default, Firefox 4 will not ask to save tabs, but instead it will always save your tabs on exit. You can restore them next time by choosing "Restore Previous Session" from the History menu, or pressing the restore button on Firefox's default home page.
    • Note: This was a decision by the developers. On this forum, we are all uncompensated volunteers here to help other users. The developes/employees of Mozilla/Firefox rarely, if ever visit here.

Also make sure you do not clear "Browsing History" when using Clear Recent History:

To display the "Save Tabs and Exit" message when closing multiple tabs, you can do the following:

  1. Type about:config in the URL/Location/Address bar and press the Enter key
  2. Accept the warning message (promise to be careful)
  3. The preferences page/list will open
  4. Filter = browser.tabs.warnOnClose
  5. If its value is set to false, double-click on it (in the lower panel) to toggle its value to true
  6. Repeat steps 4 and 5 for these following 3 preferences also:
    • browser.warnOnQuit
    • browser.warnOnRestart
    • browser.showQuitWarning
  7. See:




You need to update the following plugins:

  • Shockwave Flash 10.2 r152
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  1. Check your plugin versions on either of the following links':
  2. Update the Flash plugin to the latest version.
    • Download and SAVE to your Desktop so you can find the installer later
    • If you do not have the current version, click on the "Player Download Center" link on the "Download and information" or "Download Manual installers" below
    • After download is complete, exit Firefox
    • Click on the installer you just downloaded and install
      • Windows 7 and Vista: may need to right-click the installer and choose "Run as Administrator"
    • Start Firefox and check your version again or test the installation by going back to the download link below
    • Download and information: http://www.adobe.com/software/flash/about/
      • Use Firefox to go to the above site to update the Firefox plugin (will also install plugin for most other browsers; except IE)
      • Use IE to go to the above site to update the IE ActiveX
    • Download Manual installers.
  3. Update the Java plugin to the latest version.




After updating Java to the current version 1.6.0.24 (see above), you need to remove old versions of Java Console in your Extensions (You can see them in: Firefox button > Add-ons > Extensions OR Tools > Add-ons > Extensions if you are using the Menu Bar instead of the Firefox button). Link to instructions for removal are below. You have these old versions currently:

  • Java Console 6.0.12 true {CAFEEFAC-0016-0000-0012-ABCDEFFEDCBA}
  • Java Console 6.0.13 true {CAFEEFAC-0016-0000-0013-ABCDEFFEDCBA}
  • Java Console 6.0.14 true {CAFEEFAC-0016-0000-0014-ABCDEFFEDCBA}
  • Java Console 6.0.15 true {CAFEEFAC-0016-0000-0015-ABCDEFFEDCBA}
  • Java Console 6.0.17 true {CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}
  • Java Console 6.0.19 true {CAFEEFAC-0016-0000-0019-ABCDEFFEDCBA}
  • Java Console 6.0.20 true {CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}

Leave only Java Console 6.0.24 true {CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}; you may disable that in the Extensions if you are not a Java developer/programmer.

See instructions: http://kb.mozillazine.org/Java#Multiple_Java_Console_extensions

Modified by Helper7677

more options

Thanks for the assist. Here are the results.

For some reason, I could not get a "Restore Previous Session", the new default. However, resetting the Preferences, as instructed, worked.

more options

ajared

So that other users can find answers that have worked, please take a couple of minutes to return to the forum, sign in and click "Solved" next to my answer . Thanks.

more options

What on earth were the developers thinking when they removed this as a feature? It's such an obviously important thing. And if they decided to remove it as a default feature, why is it not at least a preference to select under options. From what I can tell it is available in a Mac environment. I can't believe that one has to go through all that just to make it happen.

more options

the suggestions allowed me to fix Firefox 4.0 on XP the last item was the one I had to change from false to true (browser.showQuitWarning) Thanks!

Modified by rt9127

more options

'THIS WORKS !!!' I am a doctor.But here is my help:

On the Mozilla home page http://www.mozilla.org/ type this:about:config And enter despite a warning box"I`ll be careful,I promise":-) Just tick it & enter.


Change the column: "browser startup page" -userset integer- from 3 to 4 by double-clicking on that link & changing 3 to 4 !

browser.startup.page;4

This idea I got from this link below.

http://www.mydigitallife.info/firefox-3-doesnt-prompt-or-warn-to-confirm-when-closing-multiple-tabs-as-warning-not-working/

Reply if it works by signing in;as others will be helped !


MaY 3RD 2011 next day.... Again it DID NOT work 'AND I had to change this "browser startup page" from 3 to 4 & it works. Can someone say if this can be permanently done,instead of on a daily basis?

Modified by dr.ilangho

more options

From 3 to 4 it works is good.this is permanent .do not close the window when shutting down;let it close by itself.Once in a blue moon , it does not work & I have to do it again ! Kool!I`m using 6.0 version jow.