Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I need fierfox 3 as i installed firefox 4 and my operating system can not run this version. Please send me to a link to downoad any version younger then firefox 4 which is where all the links in firefox send me to. thanks. Julie

  • No replies
  • 23 have this problem
  • 1 view
more options

Firefox prompted me to install the new and amazing "4" and i did and then discovered once i had replaced the newly updated version 3 i clicked on "4" to open it and the message read... "you cannot use the application "firefox" with this version of mac os X" I have mac os 10.4.11 and i will not be upgrading in the near future.

Firefox prompted me to install the new and amazing "4" and i did and then discovered once i had replaced the newly updated version 3 i clicked on "4" to open it and the message read... "you cannot use the application "firefox" with this version of mac os X" I have mac os 10.4.11 and i will not be upgrading in the near future.

All Replies (1)

more options

Firefox 4 requires at least OS X 10.5. You can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html

Mozilla are working to prevent Mac users with non-compatible systems from getting the notification about Firefox 4, and also not displaying the "Download Firefox 4" button on http://www.mozilla.com