X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 4 will not start on Windows 7 64bit

Posted

I just upgraded my installation of FF3 to FF4 and the installation seemed to go off without a hitch.

I left the "Launch Firefox now" button ticked and hit finish. Then nothing...

I can see that the process is being started (from Task Manager), but it doesn't do anything. There is no safe mode option available for me to try and restart it, so my only option is to kill it.

I have tried installing normally, advanced, "Run as administror", restaring my PC; none of these worked. Every time the process starts, but nothing happends. Not even a task bar windows comes up.

In the end I had to download (in Internet Explorer, yuk!) an older version of Firefox (3) and reinstall using this. This at least made it work again, but I still can't get FF4 working!

I updated it on my other personal PC and it worked fine (all addons the same, but older hardware).

In case it's relevant, I have heard of some annoyances with hardware acceleration and if I could get to the option to turn it off I would.

My particular hardware is: Processor: Intel(R) Core(TM) i7 CPU X980 @ 3.33GHz Memory: 12288MB RAM DDR3-1600MHz Hard Drive: RevoDrive X2 240GB Video Card: NVIDIA GeForce GTX 580 SLI Monitor: LG M237WDP 1920*1080 Sound Card: M237WDP-1 (NVIDIA High Definition Audio) Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7600) (7600.win7_gdr.101026-1503) Motherboard: Asus Rampage III Extreme

All drivers are up-to-date, bar my OS which is fully up-to-date bar having SP1 installed. No other application are having problems.

Any help would be greatly appreciated.

Thanks.

Chosen solution

geezus.. you have to be a frkn programmer to figure this stuff out. Def not user friendly software unless you know a lot about computers. This worked for me too:


How I fixed it:

◦ Download the latest Firefox .

◦ Install Firefox 4 (as Standard) in-place upgrade .

◦ Before finishing, un-tick the "Run Firefox Now" button .

◦ Hit Finish .

◦ Find Firefox in the Start Menu and hold Shift and click the executable (safe mode) .

◦ Leave everything disabled .

◦ You should now have a working Firefox! .

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.2 r152
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Version 1.1.7, copyright 1996-2011 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

No, browser fails to start completely!

coedjoewig 0 solutions 1 answers

I had this problem and firefox eventually worked after uninstalling OpenText (formerly Hummingbird) NFS and Exceed. I think they may have some mozilla plugin included though I've not looked into it in much more detail. Appreciate that's a pretty vague solution but thought it may help...

Modified by coedjoewig

Question owner

Unfortunately I don't have any of the above plug-ins installed. If only I was provided with a safe mode for FF4 when it says it has installed I would be able to validate more, but alas!

etricky 0 solutions 2 answers

I too have this problem. When this situation occurs, I have to start Firefox in safe mode and disable all addons. After that, FF will launch and then I can activate all the disabled addons. I have noticed that when I activate the IE Tab plugin or the Foxy Proxy Plus plugin, the next time FF won't launch again. However, I redo the sequence (safe mode + disable addons + launch + enable addons) and then everything starts to work as supposed to.

Modified by etricky

Question owner

Just like to say I'm still having this problem.

It's so frustrating! I want to upgrade to the latest and greatest but nothing works!

I've even fully repaired my entire Windows partition (it had some slight issues) and this still hasn't worked. Upgraded to service pack 1, still nothing.

Same type of error as well. Installs fine, then when I go to run it nothing happens. The process is running in memory, but no window displays. No add ons are killing it.

Someone help please! Come on Mozilla, you're supposed to be the best... please don't make me go to Chrome... I just don't want to but I also don't want to run broken and/or out of date software!

shpendzeneli 0 solutions 2 answers

I have same problem with firefox 4.0 ore 4.0.1 I dont know why, I have to install again firefox 3.0 and i'ts working again. Firevox 4.0 wont work :( I hope than Mozilla teem will fix this problem that it shows in Windows 7 Profesional.

XeroxSinner 0 solutions 2 answers

Sounds like the same issue I'm having. On my side it started with FF 3.x yesterday. Updated to FF4 last night. At the install process, if I launch FF4, it'll run, but once that's closed.. gg.

Question owner

Just tried FF4.0.1, still no joy.

C'mon Mozilla, fix this please! It's been months now that I can't use FF4!

Question owner

Solved it!

It was a dodgy version of Firebug (1.6.2) running, which would kill the disable/update process. It was killing something on the first run that would corrupt my Firefox.

How I fixed it:

  • Download the latest Firefox
  • Install Firefox 4 (as Standard) in-place upgrade
  • Before finishing, un-tick the "Run Firefox Now" button
  • Hit Finish
  • Find Firefox in the Start Menu and hold Shift and click the executable (safe mode)
  • Leave everything disabled
  • You should now have a working Firefox!

Remove/update your add-ons as needed. I only had to upgrade Firebug in safe mode to get it working.

Odd how the check for updates completely broke this Firefox, wonder what was so bad about Firebug.

Hope this helps at least one other person! The "Run in Safe Mode" option is so hard to discover now when your browser is broken!

Question owner

Damn, this tool doesn't allow you to solve your own problems! Ouch!

etricky 0 solutions 2 answers

I do not have Firebug installed, but I'm very sure that the problem, in my case, is with the FoxyProxy addon. If I disable it, FF will start normally, otherwise, only in safe mode.

aantiles 0 solutions 1 answers

Try the following, and it may help you. I was not lucky after uninstalling and reinstalling the program several times, I even manually removed the Mozilla Folder under the User profile which is generally located at C:\Users\username\AppData\Local - yet it wouldn't still work. Here is what I did. I reinstalled the Program, and when you get to the point where you choose the location of the installation, I modified it to something else. By default; the program wants to get it installed at C:\Program Files (x86)\Mozilla Firefox in a Windows 7 64 bits. I changed that to C:\Program Files (x86)\Mozilla Firefoxx (see the extra x) and it worked fine after that. This indicates that some plug ins were stopping the program to work. Unfortunately, I could not tell what plug in was, but I got working that way.

Hope that helps.

Modified by aantiles

Question owner

Just to be clear, my original problem has been solved.

It was a bad plug-in. I gave the steps for debugging/fixing in my post above.

I can't mark this as solved because the forum software here won't allow my own posts to be the solution.

Hope my above comment help others. (Just remember to prevent the first run and then run in safe mode and you'll see it's all good!)

binajimster 1 solutions 2 answers

Chosen Solution

geezus.. you have to be a frkn programmer to figure this stuff out. Def not user friendly software unless you know a lot about computers. This worked for me too:


How I fixed it:

◦ Download the latest Firefox .

◦ Install Firefox 4 (as Standard) in-place upgrade .

◦ Before finishing, un-tick the "Run Firefox Now" button .

◦ Hit Finish .

◦ Find Firefox in the Start Menu and hold Shift and click the executable (safe mode) .

◦ Leave everything disabled .

◦ You should now have a working Firefox! .

Modified by binajimster

bugs4me 0 solutions 1 answers

Thanks anntiles - it works. Installed to C:\Program Files (x86)\Mozilla Firefox4 rather than allow it to install to the default C:\Program Files (x86)\Mozilla Firefox

arnyk@comcast.net 0 solutions 2 answers

The problem is that your Intel(R) Core(TM) i7 CPU X980 CPU has more than 4 cores. This is a problem that is rare, but not unique to Firefox and not unique to Intel i7s. The corresponding AMD 6 core processors fail the same way. It is not peculiar to Windows 7, or 64 bit operations either. It fails the same way in WinXP 32 bits, for example. It probably fails in Windows 2000. running on a machine with > 4 cores.

The solution is to edit BOOT.INI per http://support.microsoft.com/kb/289022. The option you want to change is called /numproc. You can do this via a GUI using MSCONFIG. Set /numproc=4 and the problem will go away. This is a reversible operation, just requiring a reboot to effect a change.