X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 4.0 and Adobe Flash Player 10 are not compatible.

Posted

I upgraded to Firefox 4.0 and immediately had trouble with it repeatedly hanging/not responding. After going through the add ons and plugins I discovered that the culprit is the Adobe Flash Player. I had just upgraded that as well. It works perfectly fine in Internet Explorer but I have to disable it in Firefox in order to use the browser. I am unable to watch videos, etc. What's the solution for this? Both Firefox and Adobe Flash are up to date. They just aren't compatible.

I've never had problems with Firefox until I upgraded to 4.0. Personally, I'd like to revert to my old version [3.6]. At least until an actual, working upgrade is available.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

hape4me 0 solutions 2 answers

Helpful Reply

Same thing here. I updated Flash to 10,2,153,1 installed and cannot load Flash apps like Facebook Scrabble using FF4.0

I reverted back to FF3.6.16 and it works fine.

Question owner

Yes, I downgraded as well and now it works fine. I think I'll wait until the glitches are ironed out before trying to upgrade again.