X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox Opens the Last Page I Viewed Instead of My Home Page

Posted

I have tried a couple of solutions listed in the help section, but this keeps happening. I have listed the solutions I have tried in the Trouble Shooting section below.

Additional System Details

This happened

Every time Firefox opened

This started when...

I installed 4.0

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Shockwave Flash 10.2 r153
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.50917.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

I have tried this solution:
Set what pages open when Firefox starts
This is a great feature you can use in addition to the home page settings. To save time you can have Firefox open the pages you were visiting the last time you used it so you can continue right where you left off.
At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP) and then click Options
Select the General panel.
In the Startup box click the drop-down menu next to "When Firefox starts:" and select what Firefox should display when it starts up.
Show my home page - Displays the home page (or home pages of course).
Click OK to close the Options window .
I have tried this solution:
Set what pages open when Firefox starts
At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP) and then click Options
Select the General panel.
In the Startup box click the drop-down menu next to "When Firefox starts:" and select what Firefox should display when it starts up.
Show my home page - Displays the home page (or home pages of course).
Show a blank page - Displays a blank page (this loads fast – no waiting for lots of tabs to load).
Show my windows and tabs from last time - Opens the pages you were visiting the last time you used Firefox so you can continue right where you left off. For more information, see Session Restore.
Click OK to close the Options window .
I have also tried this solution:
Try disabling the "resume from crash" option.
Type about:config into the locaiton bar and press enter
Accept the warning message that appears, this will take you to a list of preferences
In the filter box type crash
Double-click on the preference browser.sessionstore.resume_from_crash to change its value to false

Rosie125 0 solutions 3 answers

Tried all this: In Tools/Options choose "When Firefox Starts: Show my home page. Now, in the menu under that it should have Firefox address. If not, get to your home page and then select "Use Current Page. Now go to the Advanced tab and, down the bottom, tell FF to check if it is the defaault browser on start-up. Also, under Privacy select "accept cookies" then choose "until FF closes" from the drop-down menu. Also Tick "Clear History when FF closes. Another good, free tool that might help is CCleaner - deletes all left over cookies, history etc.

darkminxi 0 solutions 1 answers

Nope doesn't work.

nierfherder 0 solutions 1 answers

As of the last update, this does not seem to work unless you have all firefox windows closed. For example: one window is playing internet radio. second window is used for browsing. close second window. open a new second window. second window remembers the last page viewed and does not show the home page.

If you close all firefox windows, including the internet radio, firefox behaves as expected when opening a new window (goes to home page)

kitsapdaisy 0 solutions 1 answers

Just restart the computer. It worked for me.