X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Since installing FIREFOX 4, my Orbit downloader does not work on the website.

Posted

When I installed ORBIT DOWNLOADER on FF 3 the program left icons on the menu of FF that I could use to download multimedia.

This facility appears to be missing on FF4.

I would really like to continue to use FF, but I do require the downloader.

Thank you.

Modified by antongerber

Additional System Details

This happened

Every time Firefox opened

This started when...

I installed FF4

Installed Plug-ins

  • Garmin Communicator Plug-In 2.9.3.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • Shockwave Flash 10.2 r153
  • DivX Web Player version 1.5.0.52
  • Garmin Communicator Plug-In 2.9.2.0
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Axter 0 solutions 1 answers

I have the same problem. Until this is fixed, I rather go back to 3.6 version of firefox. It took me a while to find the 3.6 version. You can get it from following link: http://www.mozilla.com/en-US/firefox/all-older.html

JBod 0 solutions 1 answers

Helpful Reply

I was having the same issue. Getit would no longer appear after Firefox 4 was installed. Solved it by going to Tools > add-ons, and doing a search for Getit which returned a result for a program called Flashgot that I thought could serve as a replacement. After installing the add-on called Flashgot the Getit function was restored, go figure. Orbit just released an update that you should also install before trying this. Hope this helps.

Modified by JBod

Question owner

Orbit has now included a fix in their latest update (V4.0.0.10)

Whisper928 1 solutions 6 answers

Helpful Reply

I simply closed Firefox and did the following.

  1. Activate Orbit
  2. Open Preferences
  3. Monitoring
  4. untic/tic Firefox
  5. Opened the browser and everything was functioning again.
abar92 0 solutions 4 answers

i wil b hapy if u r ri8

abar92 0 solutions 4 answers

@whisper,dats nt true,i hav tried d same bt it does nt work

abar92 0 solutions 4 answers

yes friend I HAVE A 100% SOLUTION of your problem,just download the latest version of orbit downloader v 4.0.0.10,I have just done the same and downloaded IN THE END from youtube with firefox 4 and orbit GET IT,Here the link of latest orbit http://download.cnet.com/Orbit-Downloader/3000-2071_4-10600926.html

Modified by abar92

Bob_Tums 0 solutions 1 answers

If you have multiple Firefox profiles you may want to see if it is enabled in another. The options for OneClick under tools only appear in one of my profiles.

LastProRican 0 solutions 1 answers

I can happily say this was all you need to do to fix Orbit thanks!

MarceloTDF 0 solutions 1 answers

Gracias Whisper928

clemhova 0 solutions 1 answers

Thanks Jbod it worked perfectly.

gumayi 0 solutions 1 answers

1- close FF 2- open orbit downloader help/fix orbit 3- open FF 4- peace