X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

why is there no warning that firefox 4 doesn't run on a powermac? where can I find firefox 3.6 to reinstall?

Posted

So I responded to a prompt (while running Firefox 3.6 on my powermac) to download and install Firefox 4. Great! Well, the install and over-write of 3.6 ran smoothly, but trying to open Firefox 4 there was a message saying the hardware didn't support it. OK fine. But now I have no firefox. Where can I find 3.6.16 to install?

The Firefox 4 beta from a few months ago DID run, so this is curious.

thanks

Don

Chosen solution

Firefox 4 requires at least OS X 10.5 and an Intel Mac.

For Mac OS X 10.4.11 or Mac OS X 10.5.8 you can look at:

Firefox 3.6.x can be found here:

Read this answer in context 14

Additional System Details

This happened

Every time Firefox opened

This started when...

I installed Firefox 4 on a powermac running OS X 10.4

Installed Plug-ins

a bunch

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_4_11; en) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/4.1.3 Safari/533.19.4

More Information

"You cannot open the application Firefox 4 because it is not supported on this architecture"

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96736 answers

Chosen Solution

Firefox 4 requires at least OS X 10.5 and an Intel Mac.

For Mac OS X 10.4.11 or Mac OS X 10.5.8 you can look at:

Firefox 3.6.x can be found here:

Question owner

Thanks. The URL for 3.6 was what I needed.

GeoB 0 solutions 2 answers

Helpful Reply

This oversight is inexcusable!! I am also running 10.4.11 on a PowerPC Mac, and I received a notification advising me to update to Firefox 4.0. I checked first, and not only was there no warning that it was compatible only with Intel computers running 10.5 or higher, but it showed that it required 10.4 or higher! Mysteriously, this is gone now.

I lost everything, and now have nothing to lose by going back to Safari. You (Mozilla) axxholes have cost me a lot of time!!!

mjrucker 0 solutions 1 answers

It would have been so simple to put "system requirements" prominently on the download website!!! Instead I was notified to download 4.0, did so, it replaced 3.6 on my applications and then, of course, is inoperable! I run Mac OS 10.5.8 on a PowerPC Mac--you need to make 4.0 compatible with that operating system--PLEASE!!!!

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24398 answers

mjrucker,
That ain't gonna happen. Use the version of 4.0 that was created by other Mac users.

TenFourFox for PowerPC's running Mac 10.4.11 & 10.5.8 .
http://www.floodgap.com/software/tenfourfox/

popemov 0 solutions 1 answers

Thanks for the link. When I clicked the English US version which indicated a 3.6.16 download, it began downloading your version 4.x, which definitely does not run on a PowerPC mac running 10.5.x.

 What is peculiar about the entire episode is that the second time I performed the exact same clicks and selections, and it did download version 3.6.16.   Was that just a glitch in your system?  Or was something fixed?

Is your link broken, or are you attempting to force people over to another browser?

AnthonyGilbert 0 solutions 1 answers

I found TenFourFox a little buggy. I did like using it but it's got problems. hope they fine tune it soon. I really like how it handles speed wise.