X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Since installing version 4, on a 64 bit machine running Windows xp, I have a series of lines across the screen, and as I move the cursor, various parts of the screen are covered over by black or randomly colored areas. why?

Posted

I've given the basic information. My screen is messed up since I installed version 4. The location of the lines changes as I type, or as I change pages. And also areas get blocked out as I move the cursor.

Chosen solution

Try disabling hardware acceleration. Click on the "Tools" menu or the orange "Firefox" button, then choose "Options", go to "Advanced", and un-check the box next to "Use hardware acceleration where available".

If that solves the problem, then it means there is probably a bug in your graphics driver. Make sure your Windows system is up to date, and check for driver updates from your computer manufacturer.

Read this answer in context 5

Additional System Details

This happened

Every time Firefox opened

This started when...

Installed v. 4

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.43.5
  • Version 1.9.2.0
  • Office Plugin for Netscape Navigator
  • np-mswmp
  • npdivxplayerplugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 12.0.1.609
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"
  • Google Update
  • Shockwave Flash 10.2 r152
  • iTunes Detector Plug-in
  • DivX Web Player version 2.0.3.4
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • 4.0.60129.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Enables the interaction of Mathematica content with the latest installed version of Mathematica.

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Matt Brubeck 147 solutions 1390 answers

Chosen Solution

Try disabling hardware acceleration. Click on the "Tools" menu or the orange "Firefox" button, then choose "Options", go to "Advanced", and un-check the box next to "Use hardware acceleration where available".

If that solves the problem, then it means there is probably a bug in your graphics driver. Make sure your Windows system is up to date, and check for driver updates from your computer manufacturer.

Question owner

Yes, thanks, that solved the problem. I'll see what I can do about my graphics driver. But at least I can see what I'm doing!

crucibelle 0 solutions 1 answers

Helpful Reply

I have the same problem, but I am on Windows XP 32 bit. I shouldn't have to turn down hardware acceleration to get this working correctly. It was fine before the update. This is clearly a bug that needs to be fixed. I will, however, see about updating my video drivers.

balleluia 0 solutions 1 answers

Helpful Reply

I have only the vertical lines thing and the fix mentioned here definitely did not fix it at all. It is a really ridiculous obnoxious bug. I have Vista 64 bit and I have attached an image of what they look like. They seem to show up as I type in fields mostly and will often randomly appear or disappear.

liveneutralearth 0 solutions 2 answers

I have the same problem since upgrading to Firefox 4. Absolutely no issues with vertical lines appearing in Firefox 3.

My graphics drivers are all up to date. Running on Windows 7 64bit.

In Firefox 4, I get the vertical bars when typing text, including when using the cursor keys.

Although turning off hardware acceleration did stop the vertical lines from appearing, I also do not feel it's a perfect solution, as I'd rather have hardware acceleration on than off.

Modified by liveneutralearth

Question owner

By the way, updating my monitor drivers did solve the problem completely. I had upgraded to a digital monitor, but I hadn't deliberately upgraded the drivers for the monitor. I had to restart the machine after installing the new drivers, but since then, I have been able to use version 4 (and acceleration on) with no issues.

Hope everyone else can resolve it. But I agree that this seems more of a bug than a user problem.

Modified by jimrab

Since updating my display drivers the problem is fixed. Im running XP with32 bit Thanks for your help