X
Tap here to go to the mobile version of the site.

Support Forum

Page-up/page-down turn into browser forward/back

Posted

I'm running FF4 RC2 on Windows 7 64-bit SP1. My machine is a stock Asus UL30VT-X1K. I just installed FF4 the other day and had previously used 3.6.15. I noticed after a little bit of use that page-down was no longer paging down. Pressing page-up revealed that it acted like browser back. Following with page-down then revealed that it was acting like browser forward. Closing and reopening Firefox makes this issue go away but only temporarily. I have yet to figure out exactly what causes the functionality to change. It does not do this on my work PC which is also running FF4 on Windows 7 64-bit SP1. I have tried disabling all plugins, that does not make the issue go away. Uninstalling/reinstalling did not help either. One thing that has been triggering this issue consistently has been going to Yahoo Mail. It has happened without going to Yahoo Mail as well.

I'm running FF4 RC2 on Windows 7 64-bit SP1. My machine is a stock Asus UL30VT-X1K. I just installed FF4 the other day and had previously used 3.6.15. I noticed after a little bit of use that page-down was no longer paging down. Pressing page-up revealed that it acted like browser back. Following with page-down then revealed that it was acting like browser forward. Closing and reopening Firefox makes this issue go away but only temporarily. I have yet to figure out exactly what causes the functionality to change. It does not do this on my work PC which is also running FF4 on Windows 7 64-bit SP1. I have tried disabling all plugins, that does not make the issue go away. Uninstalling/reinstalling did not help either. One thing that has been triggering this issue consistently has been going to Yahoo Mail. It has happened without going to Yahoo Mail as well.

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • Office Plugin for Netscape Navigator
  • np-mswmp
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 10.0 r32
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • 4.0.60129.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Application Basics
Name
Firefox
Version
4.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
FoxyProxy Standard
2.22.5
true
foxyproxy@eric.h.jung
Web Developer
1.1.9
true
{c45c406e-ab73-11d8-be73-000a95be3b12}
Java Console
6.0.23
true
{CAFEEFAC-0016-0000-0023-ABCDEFFEDCBA}
FireFTP
1.99.1
true
{a7c6cf7f-112c-4500-a7ea-39801a327e5f}
Xmarks
3.9.7
true
foxmarks@kei.com
Firebug
1.7.0
true
firebug@software.joehewitt.com
Adblock Plus
1.3.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/ig
browser.startup.homepage_override.buildID
20110318052756
browser.startup.homepage_override.mstone
rv:2.0
extensions.lastAppVersion
4.0
gfx.blacklist.direct2d
2
gfx.blacklist.layers.direct3d10
2
gfx.blacklist.layers.direct3d10-1
2
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1300757466
places.history.expiration.transient_current_max_pages
127748
places.last_vacuum
1296178950
print.print_printer
PrimoPDF
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_bgcolor
false
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_bgimages
false
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_command
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_downloadfonts
false
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_edge_bottom
0
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_edge_left
0
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_edge_right
0
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_edge_top
0
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_evenpages
true
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_footercenter
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_footerleft
&PT
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_footerright
&D
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_headercenter
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_headerleft
&T
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_headerright
&U
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_in_color
true
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_margin_bottom
0.5
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_margin_left
0.5
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_margin_right
0.5
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_margin_top
0.5
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_oddpages
true
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_orientation
0
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_pagedelay
500
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_paper_data
1
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_paper_height
11.00
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_paper_size_type
0
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_paper_size_unit
0
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_paper_width
8.50
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_reversed
false
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_scaling
1.00
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_shrink_to_fit
true
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_to_file
false
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_unwriteable_margin_bottom
0
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_unwriteable_margin_left
0
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_unwriteable_margin_right
0
print.printer_HP_LaserJet_3390_/_3392_PCL5.print_unwriteable_margin_top
0
print.printer_HP_Officejet_J4500_series.print_bgcolor
false
print.printer_HP_Officejet_J4500_series.print_bgimages
false
print.printer_HP_Officejet_J4500_series.print_command
print.printer_HP_Officejet_J4500_series.print_downloadfonts
false
print.printer_HP_Officejet_J4500_series.print_edge_bottom
0
print.printer_HP_Officejet_J4500_series.print_edge_left
0
print.printer_HP_Officejet_J4500_series.print_edge_right
0
print.printer_HP_Officejet_J4500_series.print_edge_top
0
print.printer_HP_Officejet_J4500_series.print_evenpages
true
print.printer_HP_Officejet_J4500_series.print_footercenter
print.printer_HP_Officejet_J4500_series.print_footerleft
&PT
print.printer_HP_Officejet_J4500_series.print_footerright
&D
print.printer_HP_Officejet_J4500_series.print_headercenter
print.printer_HP_Officejet_J4500_series.print_headerleft
&T
print.printer_HP_Officejet_J4500_series.print_headerright
&U
print.printer_HP_Officejet_J4500_series.print_in_color
true
print.printer_HP_Officejet_J4500_series.print_margin_bottom
0.5
print.printer_HP_Officejet_J4500_series.print_margin_left
0.5
print.printer_HP_Officejet_J4500_series.print_margin_right
0.5
print.printer_HP_Officejet_J4500_series.print_margin_top
0.5
print.printer_HP_Officejet_J4500_series.print_oddpages
true
print.printer_HP_Officejet_J4500_series.print_orientation
0
print.printer_HP_Officejet_J4500_series.print_pagedelay
500
print.printer_HP_Officejet_J4500_series.print_paper_data
1
print.printer_HP_Officejet_J4500_series.print_paper_height
11.00
print.printer_HP_Officejet_J4500_series.print_paper_size_type
0
print.printer_HP_Officejet_J4500_series.print_paper_size_unit
0
print.printer_HP_Officejet_J4500_series.print_paper_width
8.50
print.printer_HP_Officejet_J4500_series.print_reversed
false
print.printer_HP_Officejet_J4500_series.print_scaling
1.00
print.printer_HP_Officejet_J4500_series.print_shrink_to_fit
true
print.printer_HP_Officejet_J4500_series.print_to_file
false
print.printer_HP_Officejet_J4500_series.print_unwriteable_margin_bottom
0
print.printer_HP_Officejet_J4500_series.print_unwriteable_margin_left
0
print.printer_HP_Officejet_J4500_series.print_unwriteable_margin_right
0
print.printer_HP_Officejet_J4500_series.print_unwriteable_margin_top
0
print.printer_PrimoPDF.print_bgcolor
false
print.printer_PrimoPDF.print_bgimages
false
print.printer_PrimoPDF.print_command
print.printer_PrimoPDF.print_downloadfonts
false
print.printer_PrimoPDF.print_edge_bottom
0
print.printer_PrimoPDF.print_edge_left
0
print.printer_PrimoPDF.print_edge_right
0
print.printer_PrimoPDF.print_edge_top
0
print.printer_PrimoPDF.print_evenpages
true
print.printer_PrimoPDF.print_footercenter
print.printer_PrimoPDF.print_footerleft
&PT
print.printer_PrimoPDF.print_footerright
&D
print.printer_PrimoPDF.print_headercenter
print.printer_PrimoPDF.print_headerleft
&T
print.printer_PrimoPDF.print_headerright
&U
print.printer_PrimoPDF.print_in_color
true
print.printer_PrimoPDF.print_margin_bottom
0.5
print.printer_PrimoPDF.print_margin_left
0.5
print.printer_PrimoPDF.print_margin_right
0.5
print.printer_PrimoPDF.print_margin_top
0.5
print.printer_PrimoPDF.print_oddpages
true
print.printer_PrimoPDF.print_orientation
0
print.printer_PrimoPDF.print_pagedelay
500
print.printer_PrimoPDF.print_paper_data
1
print.printer_PrimoPDF.print_paper_height
11.00
print.printer_PrimoPDF.print_paper_size_type
0
print.printer_PrimoPDF.print_paper_size_unit
0
print.printer_PrimoPDF.print_paper_width
8.50
print.printer_PrimoPDF.print_reversed
false
print.printer_PrimoPDF.print_scaling
1.00
print.printer_PrimoPDF.print_shrink_to_fit
true
print.printer_PrimoPDF.print_to_file
false
print.printer_PrimoPDF.print_unwriteable_margin_bottom
0
print.printer_PrimoPDF.print_unwriteable_margin_left
0
print.printer_PrimoPDF.print_unwriteable_margin_right
0
print.printer_PrimoPDF.print_unwriteable_margin_top
0
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Mobile Intel(R) 4 Series Express Chipset Family
Vendor ID
8086
Device ID
2a42
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version
8.15.11.8688
Driver Date
8-28-2009
Direct2D Enabled
false
DirectWrite Enabled
false (6.1.7601.17563, font cache n/a)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows
1/1 Direct3D 9

dsnation 0 solutions 2 answers

I'm having the same problem with the same (or similar) Asus and Windows 7 64-bit. Gmail is what triggered it for me, though avoiding gmail only helped until I opened a third tab. So damned frustrating.

I'm having the same problem with the same (or similar) Asus and Windows 7 64-bit. Gmail is what triggered it for me, though avoiding gmail only helped until I opened a third tab. So damned frustrating.
dsnation 0 solutions 2 answers

I've noticed that engaging in Google Chat on the Gmail page is a trigger for it

I've noticed that engaging in Google Chat on the Gmail page is a trigger for it
henrybondi 0 solutions 1 answers

I'm also experiencing the same issue with the PgDn and PgUp buttons acting as backwards and forward browser buttons-Asus, Win7 32 bit. Hope this gets fixed soon.

I'm also experiencing the same issue with the PgDn and PgUp buttons acting as backwards and forward browser buttons-Asus, Win7 32 bit. Hope this gets fixed soon.
firef0x 0 solutions 3 answers
This has also been reported here: https://support.mozilla.com/de/questions/796425 http://support.mozilla.com/my/questions/799752 And on bugzilla here: https://bugzilla.mozilla.org/show_bug.cgi?id=640587
HSuke 0 solutions 3 answers

Edit: paintballzero's solution below works.

=

I have a ton of plug-ins for FF4:

Shockwave Flash 10.2.153.1

Adobe Acrobat 10.0.1.434 Google Update 1.2.183.39 Microsoft Office 2010 14.0.4730.1010 Microsoft Office 2010 14.0.4761.1000 Silverlight Plug-in 4.0.60129.0 Winamp Application Detector 5.6.1.3133

ONLY the Shockwave plug-in is causing this problem. Disabling it fixes the issue. But then I can't use Flash.

Edit: paintballzero's solution below works. =========== I have a ton of plug-ins for FF4: Shockwave Flash 10.2.153.1 Adobe Acrobat 10.0.1.434 Google Update 1.2.183.39 Microsoft Office 2010 14.0.4730.1010 Microsoft Office 2010 14.0.4761.1000 Silverlight Plug-in 4.0.60129.0 Winamp Application Detector 5.6.1.3133 ONLY the Shockwave plug-in is causing this problem. Disabling it fixes the issue. But then I can't use Flash.

Modified by HSuke

paintballzero 0 solutions 3 answers

Helpful Reply

Its been reported that some of users, like me, are having this problem on their Asus model laptops. Another common factor between the models could be the use of Elantech drivers for touchpad mouses.

The bugzilla.mozilla.org link provided above has a fix that has worked for me so far. It goes as following:

1. Go to about:config

2. Find ui.elantech_gesture_hacks.enabled

3. Change its value from -1 to 0

4. Restart FF

5. If you run into a bug that option was designed to fix (non-working page swipe gestures), install the latest Elantech driver (http://www.techspot.com/drivers/driver/file/information/14513/) and reboot.

I has proven to work for me. However, I did not need to install the latest driver or have not had to so far, thus I cannot confirm that part of the fix.

Its been reported that some of users, like me, are having this problem on their Asus model laptops. Another common factor between the models could be the use of Elantech drivers for touchpad mouses. The bugzilla.mozilla.org link provided above has a fix that has worked for me so far. It goes as following: 1. Go to about:config 2. Find ui.elantech_gesture_hacks.enabled 3. Change its value from -1 to 0 4. Restart FF 5. If you run into a bug that option was designed to fix (non-working page swipe gestures), install the latest Elantech driver (http://www.techspot.com/drivers/driver/file/information/14513/) and reboot. I has proven to work for me. However, I did not need to install the latest driver or have not had to so far, thus I cannot confirm that part of the fix.

Modified by paintballzero

EasyE 0 solutions 2 answers

Sorry for what might be a simple question, but where do I go exactly to disable the elantac gesture hacks? I'm not quite sure what you mean when you say go to "about:config"

Thanks!

Sorry for what might be a simple question, but where do I go exactly to disable the elantac gesture hacks? I'm not quite sure what you mean when you say go to "about:config" Thanks!
cor-el
  • Top 10 Contributor
  • Moderator
15344 solutions 139121 answers

Helpful Reply

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold(user set).
  • Preferences can be reset to the default or changed via the right-click context menu.

See also:

To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br /> *Use the Filter bar at to top of the about:config page to locate a preference more easily. *Preferences that have been modified show as bold(user set). *Preferences can be reset to the default or changed via the right-click context menu. See also: *http://kb.mozillazine.org/about:config
EasyE 0 solutions 2 answers

Thanks! Fix worked perfectly running on an ASUS UL80VT.

Thanks! Fix worked perfectly running on an ASUS UL80VT.
hoan999999 0 solutions 1 answers

LOL @ everyone owning ULxxVTs ... I too encounter this problem on my UL80VT Stock. . .

/awkward people running into eachother/

LOL @ everyone owning ULxxVTs ... I too encounter this problem on my UL80VT Stock. . . /awkward people running into eachother/
stevehhhh 0 solutions 1 answers

I just closed firefox and re-started it Then it was ok again.

I just closed firefox and re-started it Then it was ok again.
kassel 0 solutions 1 answers

The cause on my computer (windows 7 64 bit, Firefox 8) seems to be the Adobe Flash Plugin. Disabling it restores the normal functioning of the page-up and page-down keys.

The cause on my computer (windows 7 64 bit, Firefox 8) seems to be the Adobe Flash Plugin. Disabling it restores the normal functioning of the page-up and page-down keys.