X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

saving tabs on exit

Posted

I followed the instructions to rename files in Firefox folder and tried to troubleshoot my few add-ons. Since upgrading to v4 I am no longer asked if I want to save tabs. Please advise... Thanks

Chosen solution

  • Tools>Options>Tabs: tick 'warn when closing multiple tabs'
  • Tools>Options>General>Startup: select 'open my home page'.
  • Type about:config in Location bar, hit enter, filter by browser.showQuitWarning, set it to True.

Please let us know whether that solves the issue.

Read this answer in context 80

Additional System Details

This happened

Every time Firefox opened

This started when...

I upgraded to V4

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Winamp Application Detector
  • Shockwave Flash 10.2 r152
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Office Live Update v1.5
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

As mentioned above, renamed files in Firefox folder and tried troubleshooting add-ons.
Also tried adjusting firefox>options>privacy>history>firefox will use custom settings for history>clear history>settings> all unchecked except download history and cache.

Gryllida 76 solutions 892 answers

Chosen Solution

  • Tools>Options>Tabs: tick 'warn when closing multiple tabs'
  • Tools>Options>General>Startup: select 'open my home page'.
  • Type about:config in Location bar, hit enter, filter by browser.showQuitWarning, set it to True.

Please let us know whether that solves the issue.

Question owner

Thank you Gryllida. The first two settings were mine as well. The third setting "show quit warning" was set to false. It appears to have done the trick. Thank you very much for your quick and spot on help. Much appreciated...

divrama 0 solutions 1 answers

Thank you! This worked!

Matt Brubeck 147 solutions 1390 answers

By default, Firefox 4 will not ask to save tabs, but instead it will always save your tabs on exit. You can restore them next time by choosing "Restore Previous Session" from the History menu, or pressing the restore button on Firefox's default home page.

jb7705 0 solutions 1 answers

Thanks for the info. Worked great for me as well.

dukeisduke 0 solutions 1 answers

Is there a way to make True the default, instead of a user setting? I have a couple of machines at home that all five in our family use, and it'll be a headache to go in under each profile and have to do the about:config and toggle action.

I wish you guys hadn't changed this functionality.

chuckking 0 solutions 6 answers

Well, that's nice, but it introduces 3 steps that I didn't have to do before. The idea of improvement is always to reduce steps/keystrokes when possible. They need to give us the option to default to Restore Previous Session ... grrr

Matt Brubeck 147 solutions 1390 answers

Helpful Reply

If you'd like to restore the previous session by default, open the Firefox preferences/options window. In the "General" section, next to "When Firefox starts," choose "Show my windows and tabs from last time."

liz@nola 0 solutions 2 answers

Sorry, but Firefox always has asked about saving tabs in version 3 and 4 without my changing anything. The difference in 4 is that it is now a warning that they are closing, like I used to receive if I had multiple browser windows open, and will not permit a save. I tried the Corrupted Files suggestion to add the .bak extensions to two files but this changed nothing. Will now try your next advice. Thanks for trying to help.

Modified by liz@nola

liz@nola 0 solutions 2 answers

Tried your second advice about "When Firefox starts" and it worked! So thank you very much. Problem solved.

Chraz_Ritt 0 solutions 4 answers

The automatic save helps when you allow a tech support tech to take control of your computer, and you forget to shut down Firefox. For some reason when shutting down Firefox the techs don't bother to ask what to do when the dialog box for saving comes up. This will end that issue.

mereprototype 0 solutions 1 answers

What if I don't want Firefox to always save my tabs? So far, the only issue I have with FF4 is that I don't have the option to save or close depending on my reason for closing it.

shhbabe 0 solutions 1 answers

I've made the changes to about:config recommended here and now receive the 'close multiple tabs' warning but am still not prompted to save on exit. Are there settings that need to be enabled beyond that tick box in Tools>Options>Tabs? When I select History>Restore previous session, the session restored is from a crash.

Thanks.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

It is possible that there is a problem with the files sessionstore.js and sessionstore.bak in the Profile Folder

Delete sessionstore.js and sessionstore.bak in the Profile Folder

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

If you see files sessionstore-##.js with a number in the left part of the name like sessionstore-1.js then delete those as well.

You will have to redo App Tabs and Tab Groups after deleting sessionstore.js.

See:

grafkaal 0 solutions 5 answers

This was driving me crazy! To solve it you have to make sure that all the following are set to true in the about:config page.

1 - browser.showQuitWarning

2 - browser.tabs.warnOnClose

3 - browser.warnOnQuit

For some reason the 3rd one doesn't change to True when set through the Preferences. It should now work fine.

Modified by grafkaal

grafkaal 0 solutions 5 answers

This was driving me crazy! To solve it you have to make sure that all the following are set to true in the about:config page. (type about:config in the navigation bar)

1 - browser.showQuitWarning

2 - browser.tabs.warnOnClose

3 - browser.warnOnQuit

For some reason the 3rd one doesn't change to True when set through the Preferences. It should now work fine.