Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

In v3.x clicking my programmed "close" mouse button closed only active tab, in v4 it closes entire program, how do I change it back?

  • 9 replies
  • 2664 have this problem
  • 44 views
  • Last reply by nerdgrim

more options

One feature I loved in Firefox v3.6 was closing tabs with a programmed mouse button. My Microsoft Intellimouse has a button that I programmed for the "Close" command. In 3.6, clicking this button would only close the active tab I was on. This made for fast opening and closing of tabs. It's the main feature that made me ignore all other browsers actually.

Now I got updated to v4. And now, clicking my mouse's Close button closes out the Firefox window completely, just as though I'd clicked the window close "X" in the upper right.

How can I get it back to the way it was in 3.6?

All Replies (9)

more options

Try to set the pref browser.tabs.closeWindowWithLastTab to false on the about:config page.

more options

Same problem and, browser.tabs.closeWindowWithLastTab is set to false.

more options

Thank you, but yeah, that wasn't it. True or False, same behavior.

more options

Which key sequence is send if you press that key?

more options

To provide specifics: It's a Microsoft Trackball Explorer using Microsoft Intellipoint software v8.01. This is a four-button trackball with the clickable scroll wheel being a fifth button.

I assign the command "Close" to the third button. In applications, this usually closes the document, not the app itself. In Firefox 3.x, it always closed the active tab, not the application instance. Now in v4, it closes the Firefox app itself.

more options

I have the same problem with a Microsoft Comfort Optical Mouse 3000. The problem with the mapped close button closing the program, instead of tabs, only happens in Firefox 4.0.

The close button works correctly with Chrome 10, IE8 and Firefox 3.X.

more options

i have the same problem here with wireless mouse 5000 from microsoft!pretty annoying!

more options

as i see all mices which have a problem are FROM MICROSOFT???

more options

A workaround is to use Intellipoint program-specific options:

  1. Open Microsoft Mouse properties
  2. Click "enable program-specific settings"
  3. Click "Add..." and add Firefox
  4. Choose the button you want to assign, then choose "keystroke" then press CTRL + W

This is how I have mine configured. Hope this helps.