X
Tap here to go to the mobile version of the site.

Support Forum

I cannot update my Add-Ins. I always got the error: Unexpected installation error -203 when installing add-ons. I found a workaround for Windows but I have MacOS. Can you help me?

Posted

System MacOS 10.6.6

System MacOS 10.6.6

Chosen solution

They are also for the Mac. If the first link that cor-el posted is showing information for Windows, in the right hand column underneath where it says "Help with", select Mac OS X and Firefox 3.5-3.6

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • Gecko default plugin
  • iGetterBundle
  • Picasa plugin.
  • iPhoto6
  • Adobe Shockwave for Director Netscape plug-in, version 11.0.3
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r102

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15

More Information

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsILocalFile.persistentDescriptor]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///Applications/Firefox.app/Contents/MacOS/components/nsExtensionManager.js :: getAbsoluteDescriptor :: line 406" data: no]
Source File: file:///Applications/Firefox.app/Contents/MacOS/components/nsExtensionManager.js
Line: 406

cor-el
  • Top 10 Contributor
  • Moderator
17876 solutions 161746 answers
See: *[[Unexpected installation error -203 when installing add-ons]] ---- *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions_-_Firefox

Question owner

These workarounds are for Windows. I need one for MAC OS!

These workarounds are for Windows. I need one for MAC OS!
TonyE
  • Moderator
1044 solutions 8863 answers

Chosen Solution

They are also for the Mac. If the first link that cor-el posted is showing information for Windows, in the right hand column underneath where it says "Help with", select Mac OS X and Firefox 3.5-3.6

They are also for the Mac. If the first link that cor-el posted is showing information for Windows, in the right hand column underneath where it says "Help with", select Mac OS X and Firefox 3.5-3.6

Question owner

I must have been blind. Thank you both for your help.

I must have been blind. Thank you both for your help.