X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox shows a black box when viewing YouTube videos, though Chrome doesn't.

Posted

So I tried to watch a video on YouTube, yet Firefox just shows a black box. Neither the video nor the audio will play. It doesn't crash my browser or bring up any errors, which leads me to believe that it is not a Flash Player problem.

I opened Google Chrome and tried, and it plays YouTube videos with no problems.

I restarted my computer, yet it still does not work.

Any assistance is very much so appreciated.

Additional System Details

Sites Affected

http://www.youtube.com

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Default Plug-in
  • Google Update
  • Pando Web Plugin
  • Shockwave Flash 10.2 r152
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • QUAKE LIVE
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • 3.0.40624.0
  • NPWLPG
  • Nexon Game Controller
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15

More Information

qazwsxedc 0 solutions 2 answers

I just noticed that I can view embedded youtube videos linked from other websites but I cannot view the same videos directly at youtube.com

Modified by qazwsxedc

Question owner

Yeah, I can do the same, qazwsxedc.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Helpful Reply

Does it help if you change the http link to https?


Clear the cache and the cookies from sites that cause problems.

  • "Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"
  • "Remove the Cookies" from sites causing problems: Tools > Options > Privacy > Cookies: "Show Cookies"
qazwsxedc 0 solutions 2 answers

Changing to https fixed it for me. After adding the 'S' it remained for any other video I played.

Thanks.

Modified by qazwsxedc

Uncle Spellbinder 0 solutions 3 answers

Helpful Reply

https works perfectly. But the average Firefox or YouTube user probably won't know this. Hope a real fix is in the works.

squid 0 solutions 3 answers

I am having the same problem - and the https thing is working for me. Annoying as hell though.

DjDiabolik 0 solutions 1 answers

Same problems after i have upgrade Flash Player 10.3.181.34 plugins!!

Same appening on IE9 and Firefox and i need ever to reset the cache of browser!!

It's a bug of this version ??

Ashraf.Bizerta 0 solutions 1 answers

remove Gnome Color Chooser and gtk2-module-rgba: sudo apt-get remove gtk2-module-rgba gnome-color-chooser

grafxlut 0 solutions 2 answers

Could your Content > Enable Javascript be turned off? That would make a black square... and check to see if the link still works in Safari or IE.

Modified by grafxlut

Dataslayer 0 solutions 2 answers

I use Windows 7 and I have a solution. I had this problem as well where no videos would play and the thumbnails weren't visible either.

My solution: I fixed it by disabling Flash from the add-ons menu and I also reset the preferences by going through the default pathway: C:\Users\Owner(or whatever your username is)\AppData\Roaming\Mozilla\Firefox\Profiles\xxxxxxxx.default.

Go to the JavaScript file named prefs and rename it to prefs.jsOLD and close Firefox. Then, reopen Firefox. Doing this resets Firefox's preferences to the default (what they were before you changed anything).

I also disabled hardware acceleration by going to a random video that used flash (I went to a game that plays an advertisement before loading and right clicked it, clicked settings..., and then went to the display settings [first icon on the bottom], and unchecked the hardware acceleration box).

After doing all of this, everything was fine. I was able to play an entire video with nothing messing up and was very happy so hopefully this helps!

3OMAR 0 solutions 1 answers

I use Windows Vista, Mozilla Fire Fox 8.0 this problem has been very annoying to me . . . but I did the following: 1) Cleared the Cache. 2) Clear all youtube cookies. 3) Update Shockwave plug-in. 4) Update Flash Player plug-in. 5) Cancel Hardware Acceleration. 6) Finally I upgraded Fire Fox from 8.0 to 12.

Then reloaded youtube page . . . every thing worked just FINE . . .