Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Java plug-in does not register itself for MIME type "application/x-java-applet;version=1.6" in FF4 on OS X

  • 2 replies
  • 98 have this problem
  • 21 views
  • Last reply by tcwan

more options

Go to https://nettbank.fokus.no/html/index.html?site=FONB&secsystem=ND

and in Firefox 4.0rc1 on OS X and see that the Java plug-in does not register itself as a handler for MIME type "application/x-java-applet;version=1.6".

If I have a look at about:plugins, I see this: application/x-java-applet;jpi-version=1.6.0_24 Java applet application/x-java-applet;version=1.1.3 Java applet application/x-java-applet Basic Java Applets javaapplet application/x-java-applet;version=1.2.2 Java applet application/x-java-applet;version=1.5 Java applet application/x-java-vm Java applet application/x-java-applet;version=1.3.1 Java applet application/x-java-applet;version=1.3 Java applet application/x-java-applet;version=1.1.2 Java applet application/x-java-applet;version=1.1 Java applet

This is Mac OS X 10.6.6, all software updates, Apple Java version 1.6.0_24 (19.1-b02-334).

All Replies (2)

more options

A workaround is to run Firefox in 32-bit mode. Quit Firefox. Locate the Firefox application in the Finder. Right-click it, select "Get Info". Check "Run in 32-bit mode". Start Firefox, and all is well.

more options

I found a (better) workaround. However, you'll have to edit the pluginreg.dat file, which on Mac OSX is found under:

~/Library/Application\ Support/Firefox/Profiles/<hash>.default/

(where ~ is your home directory path)

http://www.emanuelis.eu/2010/06/17/how-to-manage-firefox-plugins-in-plu...