X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Problems with "Back" button

Posted

Once I get on my first page and get to the next, it won't remember the original page but it does with everything after that. How should this be fixed? Thanks!


For example, let's start with the home page (could be any). And then we go to a new site (let's call it site 2). The "Back" button is gray and not green, hitting Backspace doesn't work, and the "Back" option isn't available when you right-click. Then you go to another page (let's call it site 3). Any of the back options work. Then go on to several more pages (sites 3, 4, 5, 6, etc...), and it'll remember all the way back to site 2 but not to the home page. Virus checks showed nothing wrong, and the settings also don't suggest anything unusual either. Will I have to uninstall and re-install Firefox, or will I have to do something else? Thanks!

Additional System Details

This happened

Every time Firefox opened

This started when...

March 11, 2011

Installed Plug-ins

Adobe Acrobat 9.4.2.220, DivX Player Netscape Plugin 6.1.0.0, DivX Web Player 1.4.0.233, downloadUpdater 1.1.0.2, downloadUpdater 1.3.0.0, Google Update 1.2.183.39, iTunes Application Detector 1.0.1.1, Java Deployment Toolkit 6.0.240.7, Java(TM) Platform SE 6 U24 6.0.240.7, Microsoft DRM 9.0.0.4503 (Plugin and Object), Microsoft Windows Media Player Firefox Plugin 1.0.0.8, Mozilla Default Plug-in 1.0.0.15, NPVeohVersion4 plugin 1.0.0.4, QuickTime plugin 7.6.9.0, RealJukebox NS plugin 1.0.3.709 RealPlayer version plugin 6.0.12.709, RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit) 6.0.12.709, Shockwave Flash 10.2.152.32, Shockwave for Director 11.5.2.602, Silverlight Plug-In 4.0.60129.0, Windows Live Photo Gallery 14.0.8081.709, Windows Media Player Plug-in Dynamic Link Library 3.0.2.629, Windows Presentation Foundation 3.5.30729.1

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.2 Safari/533.18.5

More Information

raginginferno83 0 solutions 4 answers

The answers are found below:

https://support.mozilla.com/en-US/questions/791207#answer-145871

https://support.mozilla.com/en-US/questions/784951

It seems to be something to do with McAfee Site Advisor 3.3 - A bug of some sort. When I went to tools -> addons -> extensions and disabled site advisor and restarted FireFox, the issue was no longer there. Hope this helps you.

And if those don't help, maybe this will:

https://support.mozilla.com/en-US/questions/786091

Hope this helps.

Modified by raginginferno83

Question owner

Thanks--it looks like it's a recent problem. Is there a good replacement for McAfee? Thanks again!

raginginferno83 0 solutions 4 answers

I don't know of any. The Antivirus software I use (CA) has their own kind of Site Advisor thing, but I'm not sure if its more or less accurate than McAfee... I tried to find a way to report a bug, but I haven't seen anything like that. Hopefully, someone can find a way to report the bug to McAfee so they can release a software update which would remove this annoying bug.

ormiston@netspace.net.au 0 solutions 2 answers

Useless as I no longer use McAfee, but I have just lost backspace button (essential) except by using right click. Why is it now permanently gray and inoperable? I have just added by mistake some useless Google program which I can't find but doubt if it is the cause. W.F.O.

Modified by ormiston@netspace.net.au