X
Tap here to go to the mobile version of the site.

Support Forum

when I clear history script:chrome://browser/content/sanitize.js:136 hangs, what is this?

Posted

When I "clear recent history" it hangs and "script:chrome://browser/content/sanitize.js:136" comes up and I have to stop the script to continue. This started within the last week.

When I "clear recent history" it hangs and "script:chrome://browser/content/sanitize.js:136" comes up and I have to stop the script to continue. This started within the last week.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.2 r152
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 12.0.1.609
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

JBI24 0 solutions 9 answers

@berty, thanks for the tip on Everything Search, it didn't bring anything up so i'm fairly confident i'm free of it. Still no script error message as of yet since i removed all plugins other than Flash and Acrobat, yours still holding up as well?

@berty, thanks for the tip on Everything Search, it didn't bring anything up so i'm fairly confident i'm free of it. Still no script error message as of yet since i removed all plugins other than Flash and Acrobat, yours still holding up as well?
berty 0 solutions 12 answers

Yeah, still no script error. This is the longest I've gone without getting it--about a week now. I also only have Flash and Acrobat plugins running.

For anyone else removing the Quicktime plugin, make sure you delete all the files or the entire folder. There are about six different files just for the one Firefox plugin! They're usually named npqtplugin.dll, npqtplugin2.dll, etc.

Yeah, still no script error. This is the longest I've gone without getting it--about a week now. I also only have Flash and Acrobat plugins running. For anyone else removing the Quicktime plugin, make sure you delete all the files or the entire folder. There are about six different files just for the one Firefox plugin! They're usually named npqtplugin.dll, npqtplugin2.dll, etc.
redmoss 0 solutions 1 answers

Hi everyone, I also had this exact same problem and after reading this thread and following the advice of Danziger (on the first page) the problem went away. Thank you Danziger.

The plugin check page http://www.mozilla.com/en-US/plugincheck/# was very useful. I updated Shockwave Flash and Adobe Acrobat Reader so one of these plugins was causing the problem. I suspect it was Adobe Acrobat reader as this would occasionally produce an error.

Hi everyone, I also had this exact same problem and after reading this thread and following the advice of Danziger (on the first page) the problem went away. Thank you Danziger. The plugin check page http://www.mozilla.com/en-US/plugincheck/# was very useful. I updated Shockwave Flash and Adobe Acrobat Reader so one of these plugins was causing the problem. I suspect it was Adobe Acrobat reader as this would occasionally produce an error.
rko31415 0 solutions 3 answers

bassfoot's solution worked (unchecking cookies) ... but I 'downgraded' to 3.6.17 when my automatic signon feature stopped working and I thought it might have had something to do with all the 'fixes' I tried on this post ... What a difference!

3.6.17 gives a very noticeable performance improvement over 4.0 once you've tried 4.0 for a while (on my weakling Evo n410c laptop running XP)

So my recommended fix for this issue is to upgrade to 3.6.17 from 4.0.

bassfoot's solution worked (unchecking cookies) ... but I 'downgraded' to 3.6.17 when my automatic signon feature stopped working and I thought it might have had something to do with all the 'fixes' I tried on this post ... What a difference! 3.6.17 gives a very noticeable performance improvement over 4.0 once you've tried 4.0 for a while (on my weakling Evo n410c laptop running XP) So my recommended fix for this issue is to ''upgrade'' to 3.6.17 from 4.0.
berty 0 solutions 12 answers

I'm happy to report I still haven't received this error since removing all the Quicktime plugins two weeks ago. I think it's safe to say they were causing the issue.

I'm happy to report I still haven't received this error since removing all the Quicktime plugins two weeks ago. I think it's safe to say they were causing the issue.
JBI24 0 solutions 9 answers

I went 2-3 weeks without the error having removed all plugins except Flash and Acrobat, but tonight got it again for the first time. However the Microsoft Silverlight plugin had reappeared again (presumably from a Windows Update), have now removed that and fingers crossed the issue will be resolved again.

I went 2-3 weeks without the error having removed all plugins except Flash and Acrobat, but tonight got it again for the first time. However the Microsoft Silverlight plugin had reappeared again (presumably from a Windows Update), have now removed that and fingers crossed the issue will be resolved again.
Jedchase 0 solutions 3 answers

I have the same problem since upgrading. If I try to let the script continue running, it tries to open Adobe Acrobat and causes the computer to hang (the freezing is related to acrobat as the computer doesn't handle acrobat well).

I have to go into Tools>Options and individually delete the cookies.

I have the same problem since upgrading. If I try to let the script continue running, it tries to open Adobe Acrobat and causes the computer to hang (the freezing is related to acrobat as the computer doesn't handle acrobat well). I have to go into Tools>Options and individually delete the cookies.
Jedchase 0 solutions 3 answers

Now, I'm having the problem even when I individually erase the cookies.

Now, I'm having the problem even when I individually erase the cookies.
alfun 0 solutions 5 answers

I found a workaround to this problem but it is not convenient. Before you clear history close Firefox, then re-open Firefox and clear history as you normally would.

I found a workaround to this problem but it is not convenient. Before you clear history close Firefox, then re-open Firefox and clear history as you normally would.
vorlon 0 solutions 2 answers

Thanks @berty. That's the only one that worked for me on FF 10.o.2

Thanks @berty. That's the only one that worked for me on FF 10.o.2

Modified by vorlon

vorlon 0 solutions 2 answers

Try disabling "net frame assistant" in Add Ons. I fiddled with several of the fixes suggested in this forum but wasn't 100% successful. Getting rid of the Net Frame is also said to improve overall experience/performance...I tried it & I agree.

Try disabling "net frame assistant" in Add Ons. I fiddled with several of the fixes suggested in this forum but wasn't 100% successful. Getting rid of the Net Frame is also said to improve overall experience/performance...I tried it & I agree.
Walrus 0 solutions 2 answers

Disabling all the old Add-ons that wouldn't update solved the problem.

Disabling all the old Add-ons that wouldn't update solved the problem.