Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

when I clear history script:chrome://browser/content/sanitize.js:136 hangs, what is this?

  • 52 replies
  • 3209 have this problem
  • 7914 views
  • Last reply by Walrus

more options

When I "clear recent history" it hangs and "script:chrome://browser/content/sanitize.js:136" comes up and I have to stop the script to continue. This started within the last week.

All Replies (20)

more options

I have had this problem ever since updating to Firefox 4.0 running on Windows XP SP3. I found that the problem was with "cookies". If this was checked it would hang and I would get the script error message. Nothing I did would solve the problem till yesterday when I updated to the Firefox 5.0 beta and now the problem is solved. Whatever has changed in this beta release it solved the problem!

more options

I have just discovered I have this problem as well. Had to clear each item individually. Cookies and Cache could be cleared together, but it's a cookie script. Check your system for Malware as this is COULD be due to an invasive script of some sort.

more options

I updated Quick-Time and it seems to work at the moment. No more script error.

more options

Per bassfoot above, I upgraded to FF5 Beta 2 and the error seems to have disappeared, although clearing history takes just a little too long for my liking. So far so good, though.

EDIT: Guess what? I just got the script problem again. Updating to FF5 Beta 2 did NOT fix the issue. UGH.

Modified by berty

more options

Yep, this worked for me too! I went to http://www.mozilla.com/en-US/plugincheck/ and updated my Shockwave Flash Player and then I was able to clear my recent history with out the message (script:chrome://browser/content/sanitize.js:136) again. . . .hummmm, must be outdated plugin issues. - Quicktime plugin needed to be updated, but I don't use it and didn't update it. After I updated Shockwave, I didn't get that message again!

Thanks for the post Danziger : )

more options

Yep, this worked for me too! I went to http://www.mozilla.com/en-US/plugincheck/ and updated my Shockwave Flash Player and then I was able to clear my recent history with out the message (script:chrome://browser/content/sanitize.js:136) again. . . .hummmm, must be outdated plugin issues. - Quicktime plugin needed to be updated, but I don't use it and didn't update it. After I updated Shockwave, I didn't get that message again!

Thanks for the post Danziger : )

more options

Sorry myawards, but my plugins are up-to-date and I still get this error, even using Firefox 5.0 Beta 3. I'm going to keep posting here until Mozilla resolves this issue.

more options

This can be caused by clearing the cookies via Delete browsing, search and download history on Firefox.
You can try to exclude the cookies to see if that helps.
You can let all cookies expire when you close Firefox to remove unwanted cookies and keep the ones with an allow exception.

  • Tools > Options > Privacy > Cookies: "Keep until": "I close Firefox"

If you use Delete browsing, search and download history on Firefox to clear the cookies when you close Firefox then Firefox also tries to clear the cookies from plugins like Flash and starts a plugin-container process with the Flash player and possibly other plugins as well for each cookie, so that can add extra time if there are a lot of cookies to remove and cause the unresponsive script error to appear.

more options

Well, I may have finally figured it out. I removed the Quicktime plugin from Firefox and all of sudden I can clear the history without any errors. So far so good...for the past 24 hours.

I also have a suspicion that the Adobe Acrobat might be a problem as well, but I'll keep everyone updated.

more options

I've got the Quicktime plugin disabled and I'm still getting the issue berty. I think you might be onto something with the Adobe Acrobat though, i've only got that and the Shockwave Flash plugin going, and I'm guessing most people will have at least the latter going as well to watch various media online.

Also (although it's only happened 2 or 3 times in the months i've had this problem), just before the script error comes up i've occassionally had a pop-up permissions box from Abobe so i'm inclined to point the finger towards their plugins being the cause here.

When I disable the Acrobat and Shockwave Flash plugins I don't get the error message at all, but obviously that's not much of a fix seeing how many sites use them, especially the Flash.

more options

@JBI24: Try deleting the Quicktime plugin as opposed to just disabling it. That might make a difference.

The reason I brought up Acrobat is because when I clear history, two instances of AcroRd32.exe show up in the task manager, along with all those extra plugin-container.exe instances that also appear. But they don't start running anymore now that I removed the Quicktime plugin.

Also, you might want to look into overlay.xul. It's malware that hijacks search results in Firefox. I recently found I had it on two computers. I removed it a day after I deleted the Quicktime plugin, so maybe that's the real reason I'm no longer receiving the clear history error.

more options

@berty: Thanks for the advice, don't know why i didn't think of completely removing Quicktime plugin before. Got rid of it plus a few others i don't use, so fingers crossed i'll get similar results to you!

Thanks for the heads up on overlay.xul as well, i've had problems with that before on another computer but from what i can determine this comps free of it. If my script comes back after this Quicktime fix i'll turn my attentions to that though.

more options

I'm happy to report that I still haven't received this error since removing the Quicktime plugin. Any update from you JBI24?

more options

Yep same here berty, I can't thank you enough if this holds up I've spent way too much time over the last few months trying to fix this thing.

more options

I'm sad to report that I've unfortunately just got the error message again, it was a good 2 days of thinking it was fixed while it lasted though lol

more options

Problem solved by going back to 3.6.17.

This "feature" became so annoying, especially when there doesn't seem to be any kind of fix for it, that I had to go back.

And sadly this isn't the only bug with FF4, the quality has decreased greatly in this release.

Modified by tomsan22

more options

@JBI24, what plugins do you have installed right now? Did you ever look for that overlay.xul malware?

more options

@berty, I've been removing and deleting every plugin that isn't Acrobat or Shockwave since my post so i'll just have to wait and see again if the error comes back, all clear so far though.

Yeah i've run scans with a few different programs and can't find any traces anywhere, not to say it isn't there of course but from what I can tell i'm clear.

more options

@JBI24, I found I had to manually search for the file--my antivirus and anti-malware programs wouldn't pick it up. I used Everything Search to find the file quickly. You can also remove it quickly by using something called GooredFix.

more options

bassfoot's solution worked for me. all other solutions posted so far were merely short-term fixes. uncheck cookies in 'clear all history' and let firefox take care of them when you exit.

k

  1. 1
  2. 2
  3. 3