X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do i change firefox rc4's default search engine? i want google but it has yahoo

Posted

how do i change my default search engine (keyword search engine) to google? when i installed ff4rc it changed to yahoo but i dont want that.

I looked in the normal help files but what was there didn't work.

Chosen solution

Additional System Details

This happened

Every time Firefox opened

This started when...

i installed ff4rc

Installed Plug-ins

  • Zylom Plugin
  • Pando Web Installer
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r152
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • NPWLPG
  • Nexon Game Controller

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers
  1. Left-click the search engines icon on the search bar
  2. Open "Manage Search Engines"
  3. If you see the Google search engine then select it
  4. If you do not see the Google search engine then click "Restore Defaults"

Question owner

i did this and removed yahoo but when i type in something random (asdf, etc.) in the normal addres bar (not search bar) it still automatically goes to and searches with yahoo

Modified by Stchurdak

rajsudhakaran 2 solutions 5 answers

Helpful Reply

hi,

try this : 1. go to the address bar: 2. type "about:config" click on "I will be careful - I promise" 3. in the filter type “browser.search.defaultenginename” 4. Double click it and change the value to "Google" 5. Restart the browser and try making a search.

Hope this resolves your issue

Question owner

sorry, but it did not help. I tried looking through the help files and found that you can change the keyword.url but i dont know what to enter for google. its default is "http://search.yahoo.com/search?p=" and i changed it to this "http://search.google.com/search?p=" but, it just goes to the google home page and does not search

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24406 answers

Chosen Solution

The value for keyword.URL for Google should be:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

Question owner

thx alot whats funny is that i solved it right before i checked this forum again i just right clicked the value and hit reset lol :P

Edit i also tried that out and it works too

Modified by Stchurdak

xusmcvet 0 solutions 2 answers

Keyword:URLdoesn't exist in the config" file in the latest release of Firefox. And unfortunately, your fix doesn't work for me either.

What does exist in the config file is "browser.search.defaultenginename” which I did change but that has no effect on searches done from the URL/address bar.

Any suggestions anyone?

xusmcvet 0 solutions 2 answers

"Keyword:URL" doesn't exist in the config file in release 4 of Firefox. And unfortunately, your fix doesn't work for me either.

What does exist in the config file is "browser.search.defaultenginename” which I did change but that has no effect on searches done from the URL/address bar.

Any suggestions anyone?

martinjones1 0 solutions 1 answers

hey i had this trouble, reading a little here and making tryes i solved it already, going to tools - advance and make mozilla default search engine

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

It is not keyword:URL , but keyword.URL (case sensitive)

See:

Modified by cor-el

kaigun 0 solutions 2 answers

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

did not work for me. What I ended up doing is simply changing my homepage to from the default Mozilla Firefox to google.com. Is that what I wanted to do? No, but at least now I get google search results rather than yahoo, which is where the Mozilla page was taking me.

tawse57 0 solutions 1 answers

Bit of a nightmare to clean this up but this is what I did.

1. In your address bar, type in: “about:config”

2. Read the warning message and if you are unsure of what you are doing do not proceed.

3. Inside of the filter search box, type in: 'search' without the inverted commas.

You will then see a long list of urls, strings, search engine names. I merely right-clicked on each that was going to a search url I did not like, clicked on 'reset' and it reverted to a Google name or google url.

I suppose you could also use 'modify' if the 'reset' does not work.

4. Restart Firefox and you should be fine.

The problem appears to be that the urls and strings for the search choice are all over the place but by searching for, ahem, 'search' in step 3 above you find it all.

Well, worked for me.

Hope this helps.

If you are in any doubts about doing the above don't do it. Don't blame me if you break your browser.

Modified by tawse57

mark2 4 solutions 94 answers

Does this string

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

actually set Google as the default search engine,or does it set the URL bar behavior back to "browse by name" ? Just tried on the latest nightly,it apparently does this,as I type a word in the URL bar,it opens the website matching that word.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Of course it does both with that particular keyword.URL setting. There are others for the Google site as you can see in the article. If you want a different site then change the URL to that specific site.

mark2 4 solutions 94 answers

Thanks cor-el,I should have done my homework.. Lately,another issue has surfaced:rather annoyingly,Google now defaults to instant search even if searching from the URL bar with the correct string for "browse by name" http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= is there a way to tweak the no-instant query http://www.google.com/webhp?complete=0 as a replacement keyword.URL value?

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Try this URL to disable autocomplete from Google. Be aware that this page doesn't have autocomplete=off for the search bar (if it opens) on the Google page, so Firefox will remember form history if enabled.

williamh_24076 0 solutions 1 answers

Easy way.

Go to the search engine page you want to use,

say www.google.com

while on that page,

Tools>Options>General>Start Up>> When Firefox starts: Show my Home Page

Click>> Use Current Page

irbaaz 0 solutions 1 answers

the most simple step 1:write 'about:config' in the url box and hit enter 2: then click on 'i will be carefull i promise' 3: then write 'keyword.url' in the filter and hit enter 4: right click on it and select modify 4: then paste 'http://www.google.com/search?hl=en&source=hp&biw=957&bih=456&q=' in the keyword.url popup box hit enter and you done

sennekuyl 0 solutions 1 answers

@Stchurdak: Change the 'p' to a 'q'. Shorter than the other solutions'

n4Sha 0 solutions 1 answers

Open Help Tab

Restart With Add-ons Disable

Check the 2 last choises ( check the box )

D