X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Stop displaying Add-on bar?

Posted

With Firefox 4b12, on Mac Snow Leopard:

How do I stop displaying the new "add-on bar" at the bottom of the page? It takes up space and isn't useful for me. I have done View/Toobars and un-selected the Add-On bar, but it reappears every time I reopen the browser. Any way to stop it showing up by default?

Additional System Details

Installed Plug-ins

  • npmnqmp 071705000010
  • iPhoto6
  • Office Live Update v1.0
  • eMusic DLM 4.1.3.2
  • 20-20 Technologies - 20-20 3D Viewer v4.5.4.0
  • Java Plug-In 2 for NPAPI Browsers
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 4.0.60129.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.2 r152

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24404 answers

Certain extensions that place icons on the Add-on bar, or use the old Statusbar coding for icons on the Add-on, might force the Add-on bar to appear even when the users hides it. Disable your extensions one at a time to find the culprit.

grahamt 0 solutions 11 answers

As reported elsewhere a modified version of the Firefox userChrome.css file can be used to prevent the Add-on Bar being launched at Firefox restart. You can find a copy of this code in the file I have posted in my Public folder on Skydrive here: https://skydrive.live.com/?cid=8997700dc0fb2601&sc=documents&uc=1&id=8997700DC0FB2601%21119# This can be downloaded and installed in the Firefox profile chrome folder, alongside the two examples provided by Mozilla.

Macenro 0 solutions 3 answers

Helpful Reply

IF YOU HAVE FIREBUG INSTALLED!!!!!!!!! Its easy, just open a new tab and type: 'about:config' hit enter and you will be shown a warning if you have not yet disabled it and just click, 'i'll be careful, i promise!' button. Now, in the configuration tab, click to the filter and type: 'addonbar' you'll get a result like this, somewhere: 'extensions.firebug.addonBarOpened' CHANGE THIS TO FALSE. And, you're done. (restart FF)

Modified by Macenro