Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My homepage opens in different language than I have set.

  • 1 reply
  • 10 have this problem
  • 4 views
  • Last reply by wuergler

more options

I marked google.com as my homepage but while opening ffox I always see google.pl (I am in Poland but still I prefer all my settings in English). Recently the same started happening to the yahoo. Also lots of pages automatically translate into Polish which sometimes is really difficult as usually half text is Polish half English (imdb.com for instance). I marked English as my preffered language, and google.com as my homepage. How to avoid this unwanted features? Any ideas? Thanks

All Replies (1)

more options

One easy way in the case of Google is to go to http://www.google.com/ncr . However, this will stay as google.com only as long as you don't delete cookies. Also see http://www.google.com/support/websearch/bin/answer.py?hl=en&answer=873

Some sites unfortunately take localization a bit too far. Sometimes turning off "Location-Aware Browsing" may help a bit, see http://www.mozilla.com/en-US/firefox/geolocation/, paragraph "How do I turn off Location-Aware Browsing permanently?" on the bottom.