X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 4 doesn't ask me to save a session with mutiple tabs

Posted

Well with firefox 3.6 when you have multiple tabs open and close the browser it ask you if you want to save your session for later, firefox 4 only warns you about closing multiple tabs and doesn't save them for later restoring of your session. Hopes this becomes part of the final release because that is one firefox's most useful features.

Well with firefox 3.6 when you have multiple tabs open and close the browser it ask you if you want to save your session for later, firefox 4 only warns you about closing multiple tabs and doesn't save them for later restoring of your session. Hopes this becomes part of the final release because that is one firefox's most useful features.

Additional System Details

This happened

Not sure how often

This started when...

I close firefox 4 with multiple tabs opened

Installed Plug-ins

  • ArtistScope DRM plugin 1
  • 1.9.0009.1
  • ArtistScope plugin 42
  • kanevapatch
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 12.0.1.609
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Shockwave Flash 10.1 r102
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • DivX Web Player version 2.0.0.254
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.51204.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
5137 solutions 37883 answers

The prefs for the warning message have been set to false as the default in current Firefox 4 beta versions.

You can set the warn prefs on the about:config page to true via the right-click context menu or toggle with a double left-click.

   * browser.tabs.warnOnClose , see http://kb.mozillazine.org/About%3Aconfig_entries
   * browser.warnOnQuit , see http://kb.mozillazine.org/browser.warnOnQuit
   * browser.warnOnRestart , see http://kb.mozillazine.org/browser.warnOnRestart
The prefs for the warning message have been set to false as the default in current Firefox 4 beta versions. You can set the warn prefs on the about:config page to true via the right-click context menu or toggle with a double left-click. * browser.tabs.warnOnClose , see http://kb.mozillazine.org/About%3Aconfig_entries * browser.warnOnQuit , see http://kb.mozillazine.org/browser.warnOnQuit * browser.warnOnRestart , see http://kb.mozillazine.org/browser.warnOnRestart
John99
  • Moderator
971 solutions 13138 answers

I note my 4.beta behaves slightly differently than firefox 3.6 in respect to saving multiple tabs, it is opening up with a single tab but that then includes an option to restore the previous section, clicking on that does then restore the multiple tabs. Do you just need to take the extra step of clicking on restore previous session

I have not yet seen the crash & session restore screen on 4.0b12 (3.6 has the crash session restore screen saying " ... embarassing ..." )

I note my 4.beta behaves slightly differently than firefox 3.6 in respect to saving multiple tabs, it is opening up with a single tab but that then includes an option to restore the previous section, clicking on that does then restore the multiple tabs. Do you just need to '''take the extra step of clicking on restore previous session''' I have not yet seen the crash & session restore screen on 4.0b12 (3.6 has the crash session restore screen saying " ... embarassing ..." ) * see also [[Firefox does not ask to save tabs and windows on exit]]
dynfo 0 solutions 3 answers

Helpful Reply

the-edmeister, thank's for your solution but it didn't fix anything for me, however, I found a solution.

Go to 'about:config', then search for 'browser.showQuitWarning' and set it to 'true'.

Have fun.

the-edmeister, thank's for your solution but it didn't fix anything for me, however, I found a solution. Go to 'about:config', then search for 'browser.showQuitWarning' and set it to 'true'. Have fun.
John99
  • Moderator
971 solutions 13138 answers

There is a long thread on this subject, some of the posts in that thread may be of interest (comments probably apply to all OS not just Mac s ): Firefox 4.ob10 Mac: The "Save Tabs?" does not appear when quitting FF {link]

There is a long thread on this subject, some of the posts in that thread may be of interest (comments probably apply to all OS not just Mac s ): ''Firefox 4.ob10 Mac: '''The "Save Tabs?" does not appear when quitting FF''' {[https://support.mozilla.com/en-US/questions/780601 link]]''
Michael Verdi
  • Administrator
  • Moderator
128 solutions 856 answers

In Firefox 4 you have two options. If you use the default Firefox home page it will contain a link to "restore your previous session." If you have a different home page or at a later time you can go to the Firefox button, over to History (just go to the History menu in XP) and select restore previous session.

You can also set what tabs show when firefox starts in Firefox Options, under the General panel. More info on that here: How to set the home page

In Firefox 4 you have two options. If you use the default Firefox home page it will contain a link to "restore your previous session." If you have a different home page or at a later time you can go to the Firefox button, over to History (just go to the History menu in XP) and select restore previous session. You can also set what tabs show when firefox starts in Firefox Options, under the General panel. More info on that here: [[How to set the home page]]
ibrahimhamad 0 solutions 1 answers

Helpful Reply

This is the final solution

http://www.raymond.cc/blog/archives/2011/03/23/enable-save-tabs-on-exit-for-firefox-4/


   1. Type about:config at the address bar and hit enter.
   2. Click the “I’ll be careful, I promise!” button
   3. At the filter bar, type browser.showQuitWarning and hit enter.
   4. You can either double click on it to change the value from false 
        to true, or right click on it and select Toggle.

https://support.mozilla.com/media/uploads/images/2011-04-22-07-37-10-ea2586.png

This change takes effect immediately without restarting Firefox. Now try closing Firefox 4 with multiple tabs opened and you’ll be prompted to save the tabs.

https://support.mozilla.com/media/uploads/images/2011-04-22-07-38-06-54d472.png

This is the final solution http://www.raymond.cc/blog/archives/2011/03/23/enable-save-tabs-on-exit-for-firefox-4/ 1. Type '''''about:config''''' at the address bar and hit enter. 2. Click the “'''''I’ll be careful, I promise'''''!” button 3. At the filter bar, type '''''browser.showQuitWarning''''' and hit enter. 4. You can either double click on it to change the value from false to true, or '''''right click on it''''' and select '''''Toggle'''''. https://support.mozilla.com/media/uploads/images/2011-04-22-07-37-10-ea2586.png This change takes effect immediately without restarting Firefox. Now try closing Firefox 4 with multiple tabs opened and you’ll be prompted to save the tabs. https://support.mozilla.com/media/uploads/images/2011-04-22-07-38-06-54d472.png

Modified by ibrahimhamad

John99
  • Moderator
971 solutions 13138 answers

dynfo posted a similar solution, above in this thread, a month ago, and the solution was posted in the thread I initially linked to, 2 months ago: /questions/780601

''dynfo'' posted a similar solution, above in this thread, a month ago, and the solution was posted in the thread I initially linked to, 2 months ago: [/questions/780601]
robertcran 0 solutions 1 answers

This worked perfectly. The same solution as offered by dynfo earlier, but with instructions for those, like me, who had no idea what about:config was or where to find it.

Thanks.

This worked perfectly. The same solution as offered by dynfo earlier, but with instructions for those, like me, who had no idea what about:config was or where to find it. Thanks.
djsumdog 0 solutions 2 answers

I'm using Firefox 4 on MacOS and checked about:config. browser.warnOnQuit is set to true, but it still doesn't warn me on quit. Not sure how to change this. This is one things I HATED about Chrome. Apple+W and Apple+Q are wayy to close together on the keyboard. I need a warning box. I know you can restore after quit, but that's just annoying (random video tabs will start playing as you start back up...)

I'm using Firefox 4 on MacOS and checked about:config. browser.warnOnQuit is set to true, but it still doesn't warn me on quit. Not sure how to change this. This is one things I HATED about Chrome. Apple+W and Apple+Q are wayy to close together on the keyboard. I need a warning box. I know you can restore after quit, but that's just annoying (random video tabs will start playing as you start back up...)
djsumdog 0 solutions 2 answers

This is awesome! Thank you so much! I really don't understand why this isn't in the stock options dialog, or why the old "browser.warnOnQuit" wasn't removed to avoid confusion. This isn't a minor change, especially for Mac users where the Apple+W and Apple+Q are so close together.

This is awesome! Thank you so much! I really don't understand why this isn't in the stock options dialog, or why the old "browser.warnOnQuit" wasn't removed to avoid confusion. This isn't a minor change, especially for Mac users where the Apple+W and Apple+Q are so close together.