X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox won't start (not even in Safe Mode) on Windows 7 x64

Posted

I am Running Windows 7 x64 and Firefox 3.6.15.

Since the day before yesterday I am unable to start Firefox. Even in Safe Mode it just won't start.

I click the Firefox icon, the mouse cursor changes to indicate the computer is doing something. After 3 seconds or so the mouse cursor again changes back to its default state. Nothing else happens. The Task Manager in Windows shows me that an instance of firefox.exe is running, but I see no Firefox window. Then if I again click to open Firefox, another firefox.exe instance starts, but again I see no Firefox window.

There isn't even a warning about one instance of Firefox already running.

What I have tried: I have uninstalled Firefox, removed all the Firefox files and folders from c:\users\username\AppData\Local and Roamning. I re-downloaded the 3.6.15 installation package and re-installed.

No change.

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

Developer Toolbar, Firebug

Application

  • User Agent:

More Information

andyblake 0 solutions 3 answers

I removed opentext nfs solo v14 (hummingbird) it is just worked.

Question owner

I don't know what opentext nfs solo v14 is, but if that's an extension, I never used it. I re-installed Windows and then re-installed Firefox and then everything was fine. What a weird bug...

bmarx 0 solutions 11 answers

I have the same problem. The only Firefox version working is the 64bit nightly build 6.0a1. No 32Bit version of Firefox works!. Chrome, Safari and Internet Explorer all work well. Another Problem I have in this context is, that the Firefox Installer hangs in the tidy up step - even for the nightly 64Bit version. I have to kill the setup.exe process but the Installation seems to be completed.

Before my change to Win7 64Bit I had OpenText NFS Solo 14 installed on a 32Bit Windows7 and no Problems.

Is there a solution for this problem without uninstalling OpenText NFS Solo 14? I need the NFS Server at work.

Modified by bmarx

bmarx 0 solutions 11 answers

Today I discovered an OpenTextNFSSolo14x64_SerivePack4 in the service area of OpenText which solved the problem.

See this help topic: Firefox 32Bit won't start after Open Text NFS Solo 14 installation


Firefox 4.01 is now running again.

Modified by bmarx

rockledge 0 solutions 1 answers

I found a solution that worked for me. Right click on Foxmail, click on the "Compatability" tab, and click "Disable Visual Themes".

 I did this and it seems to have worked, even though my version of windows doesn't show in the "run in compatability mode" options.
 I hope this helps others, this was a real pain in the ass.