Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My form autocomplete shows blank drop down menus with 'Form History' still stated beside the blanks when I type in entries I previously entered.

  • 7 replies
  • 23 have this problem
  • 68 views
  • Last reply by Law_Guy

more options

It is remembering what I entered, but the options are blank. Please help, this is really annoying. I also lose form history (when it was working properly) after I leave Firefox idle for more than 5 minutes. It's been like that for a long time, but my form history (autocomplete) used to stay intact if I left the computer for a bit. I know exactly how to use my privacy options, they are set the way I always had them set when form autocomplete used to work properly for me.

Modified by vixipixie

All Replies (7)

more options

Do you have that problem when running in the Firefox SafeMode?
http://support.mozilla.com/en-US/kb/Safe+Mode
Don't select anything right now, just use "Continue in SafeMode."

If not, see this:
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+theme...

more options

Ok, I've never tried safe mode before, so I just tried it on your advice, my form history displayed! Now what? I have no idea which extension, theme etc. might be causing the problem..

more options

I just looked at the second link you provided and decided to try to reset toolbars and controls and my form history worked again! I then tried switching back to the theme I was currently using and the problem resurfaced. So I guess I know now it was the certain theme that was causing it. Thank you so much for your help!! Any idea what I can do to stop my form history from deleting after I leave Firefox idle for more than 5 minutes?

Modified by vixipixie

more options

Well, I wrote too soon, my form history is still problematic when I exit Firefox and go back in even with the default theme. I guess I have to keep trying to figure out what is causing the problem.

Modified by vixipixie

more options

I don't have many extensions so I decided to disable them one by one, and it looks like it's my google toolbar. Will uninstalling and re-installing it help?

more options

Yep, this is def a problem with the google toolbar. I did find that if you turn off the google autofill, you can keep the toolbar enabled and the problem goes away. The browser then uses Firefox's autofill instead. Thanks for leading me down the right track. I didn't want to lose Google toolbar, but not having form history has been a pain, since i use it for shipping packages and not having it makes it time consuming.

more options

Hi all,

I am having the same annoying problem.

I just disabled the autofill option in the Google Toolbar, and sure enough, my form history appears to be working again!

It's too bad... I liked the autofill feature for my addresses and so forth.

Any further resolution on this? The google support site isn't great...