Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Address bar doesn't respond to <return> key after typing a URL

  • 4 replies
  • 149 have this problem
  • 35 views
  • Last reply by ericziko

more options

Win 7 64 bit FF 4 b12.

Why does the return key not work after typing a url? Its annoying to have to use the mouse to click on the "go" button.

Also there is no "Check for updates" button, not so much for FF but for addons.

Thirdly, the addons bar does not show my addons eg Flashgot, Addblock.

Thnx

Chosen solution

You don't need to press Return key. Type the URL, press enter key and the URL will be loaded. Now to Check for Updates -

Update Firefox : Click the Firefox button, now click on the arrow right to "Help" and select About Firefox. The About Firefox dialog box should show "Checking for Updates". After sometime you should receive "Firefox is up to date".

Update Add-ons : In the Add-ons Manager, left to the "Search all add-ons" box, click the bolt-shaped icon, and select Check for Updates.

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

You don't need to press Return key. Type the URL, press enter key and the URL will be loaded. Now to Check for Updates -

Update Firefox : Click the Firefox button, now click on the arrow right to "Help" and select About Firefox. The About Firefox dialog box should show "Checking for Updates". After sometime you should receive "Firefox is up to date".

Update Add-ons : In the Add-ons Manager, left to the "Search all add-ons" box, click the bolt-shaped icon, and select Check for Updates.

more options

The return key not working can be caused by an incompatible extensions. Try the procedure in the following link - https://support.mozilla.com/kb/Troubleshooting+extensions+and+themes

more options

Many thnx for the answers. The return key problem was, as suggested, an incompatible add-on, in this case AVG Safe Search.

more options

The latest version of Illuminations for developers (1.1.10) seems to have caused this on my machine