X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My keyboard layout has changed. I no longer have an @ key.

Posted

About an hour ago, my keyboard layout changed (but only when using firefox) so that, for example, Shift+2 no longer produces @, but rather double quotes ("). Also, pressing the [ key now produces nothing, but the next key I hit after it will produce a hat. Example, the [ key and a g will give ^g. There are other peculiarities, such as the / key now shows é, and a few others.

Everything I check on the internet seems to be telling me the problem lies in my keyboard layout settings in Windows, and possibly having to press LeftAlt+LeftShift (or just Alt+Shift) to readjust them, or bringing up the language bar, etc. But all of my efforts to fix language indicate to me that I'm currently operating with a US keyboard layout (which is what it`s supposed to be), and again, this ONLY happens in firefox and no other programs.

Any ideas?

Additional System Details

This happened

Every time Firefox opened

This started when...

Not doing anything strange. About an hour ago.

Installed Plug-ins

  • np-mswmp
  • Winamp Application Detector
  • Shockwave Flash 10.1 r85
  • 4.0.60129.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96798 answers

Helpful Reply

See:

It is possible that you have switched the keyboard layout by accident.

  • Make sure that you have the Language bar visible on the Windows Taskbar.
  • You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar.
  • Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar.
  • You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application.
  • The default keys to rotate the layout is a combination (Ctrl+Shift or Alt+Shift) that can easily be used in Firefox to activate a menu item.
  • To avoid an unintentional switch assign a specific key sequence (Alt/Ctrl+Shift+number) to select keyboard layouts and remove the key combination to rotate layouts (Alt+Shift or Ctr+Shift)
julielaplante2000 0 solutions 1 answers

I have exactly the same problem. Alt+Shift doesn't do anything and my keyboard layout in Windows is OK. Only happens in Firefox. This problem has been going on for years, the only way to fix it is by restarting Firefox. I would really like to know what is the real keyboard shortcut to shift from one layout to another because the Alt+Shift clearly doesn't work. It's getting really annoying.

NoraGallaway 0 solutions 1 answers

Do you possibly have 2 letters on the right on your taskbar, that says EN? it should say that

i have German (DE) as another language on my computer, and i accidentally switched it to that, and i had the exact same problem, but with different characters

If its anything other than EN (english) on your taskbar, click on it and select it.

that solved my problem, idk if it will yours or not though

I also have an old compaq presario laptop, so it could be just specific to this, but idk

FluxTilt 0 solutions 1 answers

Thanks a lot cor-el, I didn't realize the language settings were application-specific. I always hide the language bar but knew about the keyboard shortcut, so I was especially confused when it didn't work.