Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I log on to firefox I get the an urgent message I need to update now, when I do and download the update it will not load on my computer

  • 1 reply
  • 2 have this problem
  • 3 views
  • Last reply by TonyE

more options

My computer is running XP Pro with a high speed DSL connection to the internet. When I log onto Firefox I get an urgent message saying I am the version I have is no long protected and I need to update my version. When I download the new version and try to install it the next time I log on to Firefox I get the same urgent message. I have turned of my anti-virus and tried to install it and it does not help it still won't load. I have tried to load a new version several times with no success. What is the problem?

All Replies (1)

more options

This can happen if you have an incorrect user agent string (identifies the version of Firefox). Some add-ons modify the user agent string causing it to show an old version of Firefox even if you have the latest version installed.

Your user agent string is "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16 Mnenhy/0.7.5.666"

It is reporting that you have Firefox 2.0.0.16, but the user agent string may have been locked by the "Mnenhy" add-on

Try resetting the user agent string to see if it resolves the problem. For details of how to do that see https://support.mozilla.com/kb/Websites+or+add-ons+incorrectly+report+incompatible+browser