X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My browser doesn't have a URL box or a forward/back button

Posted

What do I need to do to get this?

And come to think of it, I liked my old mozilla just fine and somehow all my settings disappeared and it got hijacked by Bing. What's going on?

Additional System Details

This happened

Just once or twice

This started when...

I don't know when . . a few weeks ago . .

Installed Plug-ins

  • Logitech Device Detection
  • Office Plugin for Netscape Navigator
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.0 r45
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • NPWLPG
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 GTB7.1 ( .NET CLR 3.5.30729; .NET4.0C) SearchToolbar/1.2

More Information

Gryllida 76 solutions 892 answers

Hey,

Please try these steps:

  1. Go to Tools, Addons, Extensions,
  2. Select Bing toolbar extension,
  3. Disable or uninstall it,
  4. Restart Firefox.

Does this work for you?

Question owner

Hmmm . . Bing isn't the problem now. It's primarily the URL box and forward/back buttons that are the problem.

Any idea why my entire former mozilla set-up got erased?

Gryllida 76 solutions 892 answers

Run Troubleshoot Firefox issues using Safe Mode, tick 'reset toolbars and controls', click 'save changes and restart'.

Does that work to bring the buttons back?

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Helpful Reply

Does View > Toolbars > [X] Navigation Toolbar have a check mark?

Question owner

Hi again,

I appreciate your help . .

There's no bar that says file, tools, view, (other?) OR URL box, reload button or back/forward buttons, so I can't even do some of the things people are suggesting. The suggestions I'm getting all require using the bar that I don't have. I also uninstalled and reinstalled firefox to see if it would change, but it didn't. I've still got the same problem.

Would LOVE to take care of this soon. It's causing me to put some projects on hold.

Annette

Question owner

Hi again,

There's no bar that says file, tools, view, (other?) OR URL box, reload button or back/forward buttons, so I can't even do some of the things people are suggesting. The suggestions I'm getting all require using the bar that I don't have. I also uninstalled and reinstalled firefox to see if it would change, but it didn't. I've still got the same problem.

Would LOVE to take care of this soon. It's causing me to put some projects on hold.

Annette

Question owner

Running in safe mode requires that I have a file button to click on, one of the things I'm missing . .

Helper7677 165 solutions 1653 answers

Helpful Reply

"There's no bar that says file, tools, view, (other?)": see Menu Bar below.

"OR URL box, reload button or back/forward buttons": See Other Toolbars below (Navigation Toolbar)

Menu Bar (File, Edit, View, History, Bookmarks, Tools, Help)
Firefox 3.6.x versions allow the user to hide the Menu Bar.

  • Tap the ALT key or the F10 key, Menu Bar will display, click View, click Toolbars, click Menu Bar to place a check mark next to it, OR
  • Press and hold the ALT key while pressing the letters VTM on your keyboard, then release the ALT key
  • See: http://support.mozilla.com/en-US/kb/Menu+bar+is+missing

Other Toolbars, see: https://support.mozilla.com/en-US/kb/Back+and+forward+or+other+toolbar+items+are+missing
Status Bar: click View, click Status Bar to place a check mark
Full Screen Mode: If you have no Toolbars or Tab Bar: Press F11 (F11 is an on/off toggle). See: http://kb.mozillazine.org/Netbooks#Full_screen

Also see:




Safe Mode




Other issues needing your attention

The information submitted with your question indicates that you have out of date plugins with known security and stability issues that should be updated. To see the plugins submitted with your question, click "More system details..." to the right of your original question post. You can also see your plugins from the Firefox menu, Tools > Add-ons > Plugins.

  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • Shockwave Flash 10.0 r45
    • Very old version
    • Security update version 10.2.152.26 released 2011-02-08
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
    • 3 updates behind
    • Security update version 1.6.0_24 released 2011-02-10
  1. Check your plugin versions: http://www.mozilla.com/en-US/plugincheck/
    • Note: plugin check page does not have information on all plugin versions
  2. Update Adobe Reader (PDF plugin):
    • From within your existing Adobe Reader (if you have it already installed):
      • Open the Adobe Reader program from your Programs list
      • Click Help > Check for Updates
      • Follow the prompts for updating
      • If this method works for you, skip the "Download complete installer" section below and proceed to "After the installation" below
    • Download complete installer (if you do NOT have Adobe Reader installed):
      • Use the links below to avoid getting the troublesome "getplus" Adobe Download Manager and other "extras" you may not want
      • Use Firefox to download and SAVE the installer to your hard drive from the appropriate link below
      • Click "Save to File"; save to your Desktop (so you can find it)
      • After download completes, close Firefox
      • Click the installer you just downloaded and allow the install to continue
        • Note: Vista and Win7 users may need to right-click the installer and choose "Run as Administrator"
      • Download link: ftp://ftp.adobe.com/pub/adobe/reader/
        • Choose your OS
        • Choose the latest #.x version (example 9.x, for version 9)
        • Choose the highest number version listed
          • NOTE: 10.x is the new Adobe Reader X (Windows and Mac only as of this posting)
        • Choose your language
        • Download the file, SAVE it to your hard drive, when complete, close Firefox, click on the installer you just downloaded and let it install.
        • Windows: choose the .exe file; Mac: choose the .dmg file
    • Using either of the links below will force you to install the "getPlus" Adobe Download Manager. Also be sure to uncheck the McAfee Scanner if you do not want the link forcibly installed on your desktop
    • After the installation, start Firefox and check your version again.
  3. Update the Flash plugin to the latest version.
    • Download and SAVE to your Desktop so you can find the installer later
    • If you do not have the current version, click on the "Player Download Center" link on the "Download and information" or "Download Manual installers" below
    • After download is complete, exit Firefox
    • Click on the installer you just downloaded and install
      • Windows 7 and Vista: may need to right-click the installer and choose "Run as Administrator"
    • Start Firefox and check your version again or test the installation by going back to the download link below
    • Download and information: http://www.adobe.com/software/flash/about/
      • Use Firefox to go to the above site to update the Firefox plugin (will also install plugin for most other browsers; except IE)
      • Use IE to go to the above site to update the IE ActiveX
    • Download Manual installers.
  4. Update the Java plugin to the latest version.
cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers
  • In Firefox 3.6 versions on Windows and Firefox 4 on Windows and Linux it's possible to hide the "Menu Bar" via "View > Toolbars" or via the right-click context menu of a toolbar.
  • Press F10 or press and hold the Alt key down to bring up the "Menu Bar" temporarily.
  • Go to "View > Toolbars" or right-click the "Menu Bar" or press Alt+V T to select which toolbars to show or hide (click on an entry to toggle the state).

See also:


You can also try:

Rasgwilson 0 solutions 1 answers

I could not find Bing anywhere in tools menu. It was deeply embedded. Here is how I un-Binged my computer.

I typed "about:config" in my tool bar. Disregard the warranty warning message and continue. I found Bing listed twice in my list. One place was "browse.search.selectedengine" the other was "browser.search.order3". I changed both options to google, closed the "about:config" window and reopened my Mozilla search engine. My toolbar search was changed to google.

In my opinion, Bing is a nasty, unwanted intrusion! Glad it is GONE!