X
Tap here to go to the mobile version of the site.

Support Forum

Firefox is not saving history even with remember history preference turned on.

Posted

Firefox is not saving history even with remember history preference turned on. I have tried reinstalling Firefox but this has not solved the issue. Any help with this is greatly appreciated.

Firefox is not saving history even with remember history preference turned on. I have tried reinstalling Firefox but this has not solved the issue. Any help with this is greatly appreciated.

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Runs Java applets using the latest installed versions of Java. For more information: Java Embedding Plugin. Run version test: Java Information.
  • npmnqmp 07076003
  • Picasa plugin.
  • DivX Web Player version 1.4.0.233
  • iPhoto6
  • Office Live Update v1.0
  • The iLok Client Helper Plug-in v3.4 allows you to use iLok.com to manage your iLok hardware keys. For more information, visit the iLok.com Web site.
  • 4.0.50917.0
  • Java Plug-In 2 for NPAPI Browsers
  • Shockwave Flash 10.1 r102
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12017 solutions 111660 answers

You can look at these prefs on the about:config page to make sure that you keep history.

* Make sure that you do not use [[Clear Recent History]] to clear the Browsing History. * Make sure that the History is set to at least 1 day: Firefox > Preferences > Privacy > History: "Remember visited pages for at least" * Make sure that you do not run Firefox in Private Browsing mode (Tools > Stop Private Browsing is grayed, see [[Private Browsing]]) * To see History and Cookie settings in Firefox > Preferences > Privacy, choose the setting "Firefox will: Use custom settings for history" You can look at these prefs on the about:config page to make sure that you keep history. *http://kb.mozillazine.org/browser.history_expire_days (180) (also affects saved form data) *http://kb.mozillazine.org/browser.history_expire_days_min (90)

Question owner

Thank you for your prompt reply. Unfortunately none of the recommendations fixed the issue. I should add that this has not always been a problem. History used to work. Not sure this is a clue but when I view the history folder, I get no results. Here's a screen shot.

Thank you for your prompt reply. Unfortunately none of the recommendations fixed the issue. I should add that this has not always been a problem. History used to work. Not sure this is a clue but when I view the history folder, I get no results. Here's a screen shot.
SmoothMc40 0 solutions 1 answers

i can't change "FireFox will to "remember history". it seems like it defaults back to "use custom settings for history" every time.

i can't change "FireFox will to "remember history". it seems like it defaults back to "use custom settings for history" every time.
cor-el
  • Top 10 Contributor
  • Moderator
12017 solutions 111660 answers

Only if all settings are the default then you will see "Firefox will: (Never) Remember History".
The "Use custom settings for history" choice reverts to "(Never) Remember history" if all History and Cookies settings are the default.
If you see "Use custom settings for history" then at least one of the History / Cookie settings is not the default.

Only if all settings are the default then you will see "Firefox will: (Never) Remember History".<br /> The "Use custom settings for history" choice reverts to "(Never) Remember history" if all History and Cookies settings are the default.<br /> If you see "Use custom settings for history" then at least one of the History / Cookie settings is not the default.<br /> <br />
Flawz 0 solutions 1 answers

i know its late, but for people who are searching for an answer, there are only 2 reasons ur history isnt being saved- check ur settings, they are f'ed up, or u changed the time and date of ur pc, change it back to regular time and it should be fixed

i know its late, but for people who are searching for an answer, there are only 2 reasons ur history isnt being saved- check ur settings, they are f'ed up, or u changed the time and date of ur pc, change it back to regular time and it should be fixed