X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

i cant open picasa web albums in firefox

Posted

google says they cant find Picasa website

Additional System Details

Sites Affected

http://www.picasawebalbums.com

Installed Plug-ins

  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"
  • Shockwave Flash 10.1 r85
  • iTunes Detector Plug-in
  • Picasa plugin
  • 4.0.51204.0
  • MSN® Toolbar
  • Virtual Earth 3D 4.00100226006 plugin for Mozilla
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)

More Information

peta.cheese 0 solutions 2 answers

picasa opens web albums in internet explorer?

Windows XP: http://www.freeemailtutorials.com/microsoftWindows/defaultWebBrowserOnWindowsXP.cwd

Windows 7: Start > Default Programs choose Set you default programs Pick firefox from the list and set this program as default

cffdrnkr 0 solutions 4 answers

I have Windows 7 and Picasa opens with Internet Explorer, Chrome but not with Firefox or Aurora. The pages are there, but no pictures are shown. The first one is the page in Aurora and the second one is the same page in Chrome.

It worked fine in Firefox a while back, but I guess somewhere with the updates something happened.

Vivi88 0 solutions 1 answers

I have the same problem, and setting Firefox as the default browser didn't help. Whenever I try to access Picasa Webalbum with Firefox, the following Google error message shows up:

414. That’s an error.

The requested URL /accounts/ServiceLogin... is too large to process. That’s all we know.

However, as mentioned above, the site works fine in Internet Explorer.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Locking this old thread. If you still have problems then please create a new thread.