X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

my addons or plugins wont load

Posted

my addons wont load. Then I go to find through their websites and then this error pops up

sec_error_expired_certificate

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.1 r102

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3198 solutions 24426 answers

Is the date / time set correctly on that PC?