X
Tap here to go to the mobile version of the site.

Support Forum

I cannot get my add-ons to install. I get an error message. I had 3.0.19 working fine and had to reformat and somehow it will not restore via mozbackup the original way I had it. What am I missing?

Posted

I am trying to mnaintain my sanity when browsing and had No-Script, Request Policy and Ad Block installed and working well. I made a mistake and some malware got in there. I reformatted my drive and tried to restore via Moz backup but it will not install any add-ons in ANY version I have tried thus far.

I am trying to mnaintain my sanity when browsing and had No-Script, Request Policy and Ad Block installed and working well. I made a mistake and some malware got in there. I reformatted my drive and tried to restore via Moz backup but it will not install any add-ons in ANY version I have tried thus far.

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 12.0.1.633
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Shockwave Flash 10.2 r152
  • DivX Web Player version 2.1.1.94
  • DivX VOD Helper Plug-in
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Adobe Acrobat Plug-In Version 7.00 for Netscape
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.19) Gecko/2010031422 Firefox/3.0.19

More Information

Svetlana 76 solutions 915 answers

To install an extension, please visit http://addons.mozilla.org , find it there by name and hit the big green install button. What happens?

To install an extension, please visit http://addons.mozilla.org , find it there by name and hit the big green install button. What happens?

Question owner

like I said, I get an error message when I try to install any of them. I tried to use a backup profile of version 3.0.19 that worked and now it will not install any and I mean ANY add-on. I get an error message telling me so.

like I said, I get an error message when I try to install any of them. I tried to use a backup profile of version 3.0.19 that worked and now it will not install any and I mean ANY add-on. I get an error message telling me so.
Svetlana 76 solutions 915 answers

What is the error message?

What is the error message?
David Tenser 30 solutions 310 answers

Might be totally unrelated to the problem you're having, but saying it since it's still important: you should definitely upgrade to Firefox 3.6 asap, as 3.0.x is no longer supported by Mozilla. This means that you're no longer patched for security holes and are exposed to online threats like viruses, etc.

Upgrading is easy - just go to mozilla.com and download the latest and greatest version of Firefox. Good luck!

Might be totally unrelated to the problem you're having, but saying it since it's still important: you should definitely upgrade to Firefox 3.6 asap, as 3.0.x is no longer supported by Mozilla. This means that you're no longer patched for security holes and are exposed to online threats like viruses, etc. Upgrading is easy - just go to mozilla.com and download the latest and greatest version of Firefox. Good luck!

Question owner

I did install the latest version. I have been defeated. I am driven crazy by flash ads that I formerly was able to block and not cannot. Have you ever tried to read a book with someone waving a hand in your face continuously? I still cannot get it to install ANY add-ons. Might I have a problem with the old profile that I restore to the new version??? I'm thinking that THAT might be the case. Any thoughts???

I did install the latest version. I have been defeated. I am driven crazy by flash ads that I formerly was able to block and not cannot. Have you ever tried to read a book with someone waving a hand in your face continuously? I still cannot get it to install ANY add-ons. Might I have a problem with the old profile that I restore to the new version??? I'm thinking that THAT might be the case. Any thoughts???
Svetlana 76 solutions 915 answers

Make a new profile and try installing add-ons there: Profile Manager - Create, remove, or switch Firefox profiles

Make a new profile and try installing add-ons there: [[Managing profiles]]

Question owner

I'll give that a burn. Thanks!

I'll give that a burn. Thanks!
Svetlana 76 solutions 915 answers

Please let us know how that works.

Please let us know how that works.