X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Beta 11 renders pages more slowly than Beta 10

Posted

Hi everyone, I have a unique issue with Beta 11.

In Beta 10, whenever I clicked on a link to view a new page within a website, the page would not re-draw any elements it did not have to. This meant all background/container divs stayed in place and it almost felt like the website was completely ajaxed. It felt VERY snappy.

Now in beta 11, pages take much longer to load and actually end up re-drawing elements. It's almost as if the memory cache isn't working anymore.

Any thoughts?

Additional System Details

This happened

Every time Firefox opened

This started when...

Since the release of beta 11

Installed Plug-ins

  • O3D Plugin version:0.1.42.3
  • Octoshape embedded video plugin
  • Google Update
  • Unity Player 2.6.1f3
  • Shockwave Flash 10.1 r102
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_22 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.0.50917.0
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

More Information

Gryllida 76 solutions 892 answers

Helpful Reply

Try the trunk: http://nightly.mozilla.org

Question owner

It seems to be the same problem.

I can verify what I'm observing with actual data. According to YSlow, Beta 11 and 12 are taking a full second longer to render the pages on my site, than Beta 10 is.

Something has fundamentally changed between Beta 10 and Beta 11. I don't know if it's related to the new loading status bar in the lower left of Beta 10 or not.

EDIT: in fact, this very page renders faster in Beta 10 than in Beta 11. In Beta 11 it's around 620ms. In beta 10 it's around 530ms (both pages cached).

On my website, it's often the difference between 900ms (b10) and 1900-2000ms (b11).

I have observed similar behavior on other sites as well.

Modified by AgmLauncher

Question owner

After further investigation, I can say for sure that this is a caching issue.

I tested a heavy page on my site. According to YSlow, in Beta 11 the page was 920kb w/empty cache, and 522kb with primed cache.

In Beta 10, the exact same was 622kb w/empty cache, and just 128kb with primed cache.

Does anyone know why Beta 11 caching is different from Beta 10 caching?