Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Remove spacing between minimize mazimize close buttons.

  • 16 replies
  • 26 have this problem
  • 349 views
  • Last reply by Bijnok

more options

How remove spacing between minimize, maximize, close buttons. Problem is only in firefox, when hide menu bar.

image: http://www.bildites.lv/images/jx5yixdwdam0b5clli3.jpg

Icons should be like in my computer window.

OS: Windows XP; SP3 Theme: http://www.crystalxp.net/galerie/en.id.130.htm Firefox 4.0 Beta 10

All Replies (16)

more options

Does that glitch happen when you open 4.0beta using Help > Restart with Add-ons Disabled... ?

more options

Yes, problem is even with fresh instaled firefox

more options

Does it help if you remove the Tab bar from the title bar?

Set the pref browser.tabs.drawInTitlebar to false on the about:config page.

See http://kb.mozillazine.org/about%3Aconfig

more options

No, it doesn't help. Problem dissapears when I show menu bar.

more options

problem remains with Firefox 4.0 Beta 11

Can I fix this probles with userChrome.css?

Modified by mmittz

more options

Has anyone found a solution for this yet? I've searched everywhere, but have found little mention of the problem, let alone a fix. I have the same conditions as the original poster: XP, 3rd party visual style, and problem disappears when enabling the menu bar. My Windows caption buttons appear exactly like the posted screenshot. I would imagine CSS could fix it. Thanks,

Brandon

more options

Same here. My Firefox 4 Controls

Hope we find a solution, looks bad...

more options

These are the css rules to configure the title bar buttons. (You can use them on the userChrome.css)


#titlebar-min {

}

#titlebar-max {

}

#window[sizemode="maximized"] #titlebar-max {

}

#titlebar-close {

}

#titlebar-buttonbox{

}

#titlebar-buttonbox-container{

}

Modified by 414\/32

more options

could you post your fix?

more options

It looks like it worked for you. I don't know how CSS works. Could you post your exact input? It'd be greatly appreciated as you have offered the only helpful information.

more options

Hello again buddies, i didn't answer before because i was working :D

So lets start:

1) Create a userChrome.css (if u don't have it). How to create userChrome.css

2) Now open it and paste this:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
#titlebar-min ,#titlebar-max ,window[sizemode="maximized"] #titlebar-max ,#titlebar-close {

margin: 0px !important; padding: 0px !important; border: 0px !important; }

#titlebar-min {

width: 29px !important; margin-right: -5px !important; }

#titlebar-max {

width: 29px !important; margin-right: -5px !important; }

window[sizemode="maximized"] #titlebar-max {

width: 29px !important; margin-right: -5px !important; }

#titlebar-close {

width: 29px !important; }

3) Configure:

  • set the width to the size of your buttons (mine are 29 pixels wide)
  • set the margin right property to fix the space between the buttons.

4) Restart Firefox :D

Hope it helps

Note: i think the bug is caused by -moz-appearance and -moz-window-button-close, -moz-window-button-maximize, -moz-window-button-minimize, -moz-window-button-restore values but i don't know how to fix that! hehehe....

more options

I was sure you'd check back. Thanks a lot for your help. It looks a lot better. It was a small thing, but a big eyesore. Ha, you don't know how much I hated it. My eyes were always drawn to the corner. Big thanks again for being so helpful and being detailed with your suggestions.

Brandon

more options

Sorry for reopening this thread but is there a mean to have the top-right buttons (minimize, maximize and close) as in full-screen but in "normal" mode? (I mean using a CSS of course) I tried but can't figure it out; and when I use #titlebar-min... I can't even change the color... I join two pictures to show what I have (first one) and what I expect (second one). Don't give me the whole code if you don't want, I'd just liked an idea...

Thanks !

more options

If elements have a specific -moz-appearance then you can only change the style if you change that to:
-moz-appearance: none !important;

Modified by cor-el

more options

I inspected it with DomI and it seems there's no -moz-appearance... moreover, whatever I do, nothing happens to the button. I tried with :

  • .titlebar-min (just for the min button)
  • toolbarbutton-icon
  • titlebar-buttonbox-container
  • titlebar-buttonbox

but nothing worked... :(

more options

Finally,

I made the 3 normal buttons transparent with :

#titlebar-restore,#titlebar-max,#titlebar-min,#titlebar-close {

opacity: 0 !important; }

I could have use the class name but I find it clearer in this way.

Now I need to activate the #minimize-button, #restore-button #close-button in normal mode and that'll be nice.