Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Videos are freezing regularly in playback, every 10 seconds for 3-5 seconds and changing the browser.sessionstore.interval value did not solve this problem. Is there anything else I can do?


All videos that play through Firefox in any site experience this problem. The freeze always happens every ten seconds and can last anywhere from 3-5 seconds, making videos nearly unwatchable.

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • npmnqmp 07103007
  • iPhoto6
  • RealPlayer Plugin
  • 3.0.40818.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • LogMeIn remote control components
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r102


  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

More Information

destoo 0 solutions 8 answers

The problem is with the Flash player plugin. IE doesn't have this problem as it doesn't rely on the same flash component. Fully uninstall all flash players in your programs, then update to at least the 10.1 adobe flash player.

Question owner

How do I uninstall all Flash players? I'm on a Mac and I can't find this.

TIFF 0 solutions 1 answers

I am having this problem in IE and FF.

  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

You can start by disabling hardware acceleration in your Flash Player settings, following the same instructions that are given in this article:

Flash video won't play full screen on YouTube, Facebook and other websites

If that doesn't solve the problem, there are other troubleshooting suggestions in these articles:

martijn2011 0 solutions 8 answers

Search for:

places.sqlite (history stuff+favicons etc etc)

urlclassifier3.sqlite (google phishing url's, will be rebuild)

Must be somewhere in your profile directory...DELETE them.

dustysneez 0 solutions 3 answers

For Internet Explorer, this is what worked for me: I have Windows 7 64 bit but I read online that the Adobe Flash player for 64 bit doesn't work correctly. Go to the Adobe website & follow the directions to Uninstall Flash player for Windows 64 bit & then go back and install Adobe's Flash player for Windows 7 32 bit. This solved my video playback problem in Internet Explorer! (but not in Firefox)

For Firefox, the Flash uninstall of 64 bit and re-install of 32 bit didn't help, but so far I found 2 things that can help! If you have SEOQuake on your browser, disable it, then watch a video! This fixed the video problem for me (so far, so good anyway)! (You can enable it again anytime).

If that doesn't work, try clicking Firefox, Help, Re-Start with Add-ons Disabled. (Puts FF temporarily in Safe mode - just the browser, not Windows). Watch a video now - if it's OK it means one of your add-ons is the problem. 

Close FF, then re-start it (it will start normally with your add-ons enabled). Click Firefox, Add-Ons. Disable one of the add-ons, then watch a video. If the video still freezes, that means that one wasn't the problem. Try disabling a different one, then watch a video, etc. till you find which one was the problem!