X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

NEW LINK NEW TAB NOT WORKING

Posted

Hi,

I am Having a little annoying problem the last couple of days at first i set my browser to open any link to a new tab but recently it doesnt work anymore every link i now click just changes the current page instead of opening a new tab it is no big deal i can still use my middle mouse button to open a new tab but still i would like to have my old setting back

Modified by JinnStyle

Additional System Details

This happened

Every time Firefox opened

This started when...

4 or 5 days

Installed Plug-ins

  • getplusplusadobe16291
  • Google Talk Plugin Video Accelerator version:0.1.43.5
  • Version 1.8.0.0
  • np-mswmp
  • getplusplusadobe16263
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.4"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Pando Web Plugin
  • Shockwave Flash 10.1 r102
  • iTunes Detector Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • Windows Activation Technologies Plugin for Mozilla
  • 4.0.51204.0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 2.23.1.0 - The WorldWinner plug-in allows you to enjoy online casual games with the thrill of playing for cash and prizes

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

More Information

new link to new tab doesnt work

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

Question owner

Hi,

First of all thanks for the fast reply but the safe mode doesn't work either i followed your steps 1 by 1 but still no luck i also tried re-install firefox but no good everything is still the same

i did not install any new plug-ins or add-ons in a while so i have no idea whats causing the problem


J-S opening new tabs with middle mouse button works fine but the left button just changes the current tab

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

How are you opening links?

The setting in Tools > Options > Tabs: "New pages should be opened in": "a new tab/window" is for links that specify a target window to open the link.
That option allows you to divert such links to a new tab or to the current tab.
For other links use a middle-click or hold down Ctrl and left-click the link or use the right-click context menu.
Left-click a JavaScript (onclick) link to avoid getting a blank tab.

Shavi 0 solutions 2 answers

Helpful Reply

Uninstall the ASK toolbar from addons and problem ll be solved.

Tools>> addons >> uninstall ASK /Foxit toolbar >> Problem solved

b43y 0 solutions 1 answers

Thanks! That did the trick. I just noticed the tool bar and wondered where it came from. Do you know? E

batmanneu19 0 solutions 1 answers

I had the same problem. I then uninstalled the "Ask Toolbar" in add-ons which has installed itself somehow and the problem went away. Hope this helps anyone else!

rdijkmans 0 solutions 2 answers

I have this problem as well, and tried basically everything (also all of the solutions above). Even a fresh install (didn't help). I have this issue (using the same Logitech LX3) since I switched from Firefox 3.x to 4.x and now 5.x, all on Windows 7.

Basically, the middle mouse button behavior is totally unreliable. Most of the times, it doesn't work at all. However, sometimes it does, but then it may take up many seconds (keeping the middle button pressed) until the tab finally opens... and then it often opens multi. Sometimes the tab(s) open after X seconds while the middle mouse button is still pressed, sometimes it opens after the button was released.

It seems to be a bit better in Private Browsing mode, though. Can't really be more specific: sometimes the middle mouse button opens the new tab after seconds in "using tab x, page y, link z", while it doesn't work on exactely that same page on "using tab x, page y, link z" after doing nothing for 5 minutes.

krishna.shukla75 0 solutions 1 answers

Thx, working fine for me

digaum2003 0 solutions 1 answers

There's no ASK Toolbar here. Same problem just started today. Middle button works fine for scrolling or clicking and moving the page up and down, but when I middle-click links, nothing happens.

drowlin 0 solutions 1 answers

Helpful Reply

I disabled Tab Mix Plus 0.3.8.6, and my middle click started working as before.

sormint 0 solutions 1 answers

Tab Mix Plus 0.3.8.6 was the culprit for me too. Too bad, I LOVE TMP, but I use MMB a LOT. Whether the problem arose from a FF update or a TMP update, I'm guessing it's up to TMP to fix the problem. I hope they do.

hansioux 0 solutions 4 answers

yup, it was Tab Mix Plus 3.8.6 that ruined the middle click open link in new tab function for me too.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

If you have Greasemonkey then Update to the Greasemonkey 0.9.11 version:

See also:

chadcloman 1 solutions 5 answers

Here's what I did in Tab Mix Plus to fix this (I don't know which part actually fixed it, so I've included it all):

  1. Open the TMP options dialog
  2. Click on "Events" at the top of the dialog
  3. Click on the "Tab Opening" tab
  4. Select "Middle-click or Control-click opens items in current tab"
  5. Unselect "Middle-click or Control-click opens items in current tab"
  6. At the bottom of the dialog, under the "Inverse Middle-click or Control-click focus of:" section, select "Links"
  7. Click the Apply button
  8. Click the Close button
  9. Middle-click on a link -- it will now open in a new tab
  10. Go back into the TMP options to the same place, unselect the "Links" option that you previously selected in step #6, then Apply and Close.
  11. Middle-click on a link -- it opens in a new tab
DMWill 0 solutions 1 answers

updating Greasemonkey as suggested by cor-el immediately fixed my middle click issue. i couldn't figure out what was causing it and i didn't want to lose TMP, so a big thanks for the solution cor-el.

Oddyssey 0 solutions 1 answers

Thanks to everyone who suggested uninstalling the Ask Toolbar... worked like a charm!

NitinJain 0 solutions 1 answers

It worked, I removed Foxit toolbar.

AbdRahim 0 solutions 1 answers

Happens in Safe Mode also.