Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

is there a version supported by windows me

  • 2 replies
  • 1 has this problem
  • 3 views
  • Last reply by James

more options

need an earlier version of firefox supported by windows me

All Replies (2)

more options

Modified by cor-el

more options

Yes. Firefox 3.0 requires Windows 2000 or newer as Win95/98/ME/NT4 will not work with Firefox 3.0 or newer.

For Windows 95 it was Firefox 1.5.* as 2.0.0.* tended to freeze/crash upon startup.

Modified by James