Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I didn't like the default theme the font's are fuzz if I run in safe mode they look much better - How to fix it permenantly

  • 5 replies
  • 31 have this problem
  • 4 views
  • Last reply by andrebrait

more options

Firefox 3 was great and I liked the new features of firefox 4 but the default theme is bad or not good for my PC it is Windows 7 Prof. I added new themes and changed the graphic card setting nothing fixed it and when I tried the safe mode it worked like charm it is really pleasant so I would like to know how to make the change permanent.

Chosen solution

This is likely due to hardware acceleration. Safe mode turns off hardware acceleration, and hardware acceleration modifies the appearance of fonts.

To turn off hardware acceleration, open the Options dialog, go to the Advanced panel and then select the general tab. De-select the setting "Use hardware acceleration when available".

Read this answer in context 👍 6

All Replies (5)

more options

Chosen Solution

This is likely due to hardware acceleration. Safe mode turns off hardware acceleration, and hardware acceleration modifies the appearance of fonts.

To turn off hardware acceleration, open the Options dialog, go to the Advanced panel and then select the general tab. De-select the setting "Use hardware acceleration when available".

more options

Tony, Thank you forgot about the hardware acceleration completely.

more options

You're welcome.

For info, some of the issues concerning font rendering in Firefox 4 betas with hardware acceleration are related to DirectWrite. Microsoft have recently released an update that fixes a lot of font rendering issues whilst using DirectWrite. The update from Microsoft is available from http://support.microsoft.com/?kbid=2454826

more options

Hello Tony,

The update you've linked to sounds an awful lot like one of the ones integrated in SP1 - the fact that the update refuses to install on either of my Win7 Pro installs (1x64-bit and 1x32-bit) makes me think that this is probably the case. Even with SP1 (and subsequently, I'm assuming, the update you linked to) installed, the problem is still present.

Any other ideas? Only fix right now is to just turn off hardware acceleration...

Modified by bemymonkey

more options

The update doesn't fix it for my either.

I Had this issue using Windows 7 SP1 and nVidia GPU Now I have an ATI HD5770 with 11.2 Catalyst installed, Firefox 4.0 RC1 and it's still ugly with HW Acceleration ON.