X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox 4 100% cpu

Posted

Firefox 4 is using 100% CPU after a few minutes of browsing. It will not go away, even if you close all tabs containing Java/Flash content. The only solution is completely close the browser and re-open it but it doesn't take long for the problem to reappear. My problem is a little different than others, I don't suffer a performance hit but my fan goes into overdrive and it's using 100% of (1) core of the CPU. I can't specifically tie it to any particular Plug-in or Add-on, but can say it's happening every time I use the browser. The only solution I've found is to disable Hardware Acceleration. This is a bit disheartening, since it's a very important feature to the new browser. This happens on my MacBook Pro 13" late-2009 model, but I haven't tested it on my PC yet. I updated Java and Flash to be sure I had the latest versions. Running out of ideas... hoping someone could offer some help?

Modified by realmike15

Additional System Details

This happened

Every time Firefox opened

This started when...

Not quite sure, during one of the Firefox 4b releases

Installed Plug-ins

  • iPhoto6
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Java Plug-In 2 for NPAPI Browsers
  • 4.0.51204.0
  • Version 1.8.0.1441
  • Google Talk Plugin Video Accelerator version:0.1.43.5
  • Shockwave Flash 10.1 r102

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

More Information

alex_mayorga 12 solutions 164 answers

Does this still happen on beta 11 available at http://www.mozilla.com/en-US/firefox/all-beta.html ?

toddji 0 solutions 1 answers

It is for me. I just installed FF 4.0 Beta11 in a Windows XP VM yesterday, and found my laptop fan blowing at full speed. A look at the task manager showed firefox at 100% CPU. Stopping firefox immediately solved the problem.

I then checked another machine, this time a Windows 2000 VM running FF 4 B11, and found the same thing, 100% CPU.

Both of these were running in VMware Fusion VMs running on top of Mac OS X, on two different Macs. But, I doubt the VM aspect has anything to do with the problem.

Seirof 0 solutions 2 answers

Still happens in b11 on 32bit Linux with "hardware acceleration" option disabled.

It only happens when the browser has been left alone for a while (i.e. never during active use), and sometimes only after several days of running.

Seirof 0 solutions 2 answers

b12 seems to have fixed it for me.

mickrussom 0 solutions 8 answers

Helpful Reply

Ive downgraded from FF4 to 3.6 at this point. The CPU usage is out of control on OS X.


Still a problem on 4.0.1

groenekaktus 0 solutions 1 answers

Same problem here. After 2 minutes of browsing FireFox 4 uses 100% of one core. FF Version 4.0.1. running on Mac OSX 10.6.7

VonMagnum 0 solutions 4 answers

I get the problem sporadically on OSX 10.6.7 on my Dell Mini10V Hackintosh Netbook. It DOES go away (the 100% cpu) after about a minute or so, though. I noticed ForecastFox update itself immediately upon it going away so I can't help but wonder if there's a connection there (I sometimes get 'bad connection' listed on Forecast Fox when it seems to happen. I've disabled the plugin and will wait and see if it happens again.

The sad thing is that both Safari and Chrome (both use WebKit, I think) have a problem where if you open a new tab, the previous tab pretty much freezes up until the new tab finishes loading (huge lag anyway). Firefox4 is MUCH better on a single core CPU like this netbook in that regard (a little lag at first, but not for long; you can scroll while the other tag loads unlike Safari and Chrome). But having FF4 go to 100% CPU usage every so often is nearly as annoying (maybe more so in some respects because it freezes for a long time). I hope disabling the add-on fixes it. One a slow Netbook, it's important to have a fast browser available and they all seem to have their own drawbacks.

Rob San Diego 0 solutions 1 answers

Helpful Reply

I am beside myself and very disappointed. I can't believe Mozilla has let FireFox 4 turn into this fiasco, it used to be people flocked over to Firefox to get away from Internet Explorers slow bloated experience , and now FireFox IS the New Internet Explorer, bloated, full of terrible user experiences and not a quip from Mozilla why they rushed to releasing such a substandard product. Have you no shame? If these issues aren't resolved as soon as gmail redesigned comes out for Chrome, its "Asta La Vista Baby!" Its not as sexy as FF but at least I can reply to an email without fighting the mouse cursor to get there.

Seems Mozilla has laid a Mozzarella egg.

phobos7244 0 solutions 1 answers

I found the problem!

some Web pages use that JavaScript: http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js

it's blocking my processor to 100%

with Adblock Plus, it's easy to disable this script

injured_cowboy 0 solutions 2 answers

Where do you get the ad block plus?

bushbabywas 0 solutions 3 answers

How do you add that script to Adblock Plus? Does the text just go in the filter rule field after clicking 'add new filter'?

tawhid111 0 solutions 1 answers

Adblock plus has problems .i had similar issues do not use adblock extensions .once i removed it firefox worked like a charm ! CPU usage became normal so is the core temp to 32 !